Problems with MP Frontend and New Blog Template

I'm using Marketpress/Gridmarket and MP Frontend and Blog Template in hope of making an Etsy like site. The problem I have is that when a person registers a store, the new created store replicates the Reading settings of the main site (which is latest post) and not the blog template I created ( which has static page). Need advice. Thanks

  • Jack Kitterhing
    • Code Norris

    Hi there @Emil

    I hope you are well today and thank you for your question.

    To confirm you have set up a site to act a new blog template, that site uses a static page, but it's showing it as blog posts on the newly created sites? Can I have a screenshot of your new blog templates settings for that blog please?

    Thank you!

    Kind Regards
    Jack.

  • Emil
    • WPMU DEV Initiate

    Hey! Thanks for the quick response.

    My website is http://mycreativeteacher.com/. You have a screenshot of its reading setting below.
    The second screenshot belongs to the blog template i created that should allow registering customers to create their own store. You can see the reading settings below.
    The third screenshot belongs to a subscriber that registered for a store. His first page should go directly to My store, because it should follow the Blog Template that is set as default. Instead it follows the main site reading setting and tries to access the last post. You can see in the URL its trying to access the latest blog post that only exists on the main site (mycreativeteacher).
    How do I resolve the issue?

  • Jack Kitterhing
    • Code Norris

    Hi there @Emil

    Thank you for the screenshots, it is certainly appreciated, on screenshot number 2, you don't have a blog page defined, even if you don't want to use it, you still need to define a blog page or that can cause a issue :slight_smile:

    Then which blog ID number was used for the template?

    Thank you!

    Kind Regards
    Jack.

  • Emil
    • WPMU DEV Initiate

    Hello!

    I've defined a new page to act as Blog and set it in the Reading settings of the template. Still no change. After a subscriber logs in and wants to manage his store, as seen in picture 1, he is still redirected to Reading Settings of the main site and not the template (latest posts from the main site and not static page set in the template). The new blog template ID I created is 5. Should mention the general setting are based on sub-directories and not sub-domains. What am I missing?

  • Jack Kitterhing
    • Code Norris

    Hi there @Emil

    Thanks for the additional information and sorry to see that it still isn't working correctly for you, could you send me through some FTP details and network admin details? If that is okay with you please send to contact(at)wpmudev.org with the subject line Attn: Jack Kitterhing

    And I'll be happy to take a look for you :slight_smile:

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.