I'm using the Yoast free SEO plugin. I have added

Hi, I'm using the Yoast free SEO plugin. I have added the Alexa, Yandex, Bing codes as per the plugin. I see them between the <head> tags but when I try to verify them via Alexa, Yandex, and Bing, I get messages that says they can't be verified. I'll give you my URL but I don't want it to show up in a public thread ([removed for member privacy])

  • Tyler Postle

    Hey Wadams,

    Thanks for your question. I've removed the website from your original post :slight_smile: we have can see it on your profile since you have our dashboard installed. If you have it installed on more than 1 site just give us part of the domain or something like that so we know which one it is. That way you won't have to post the url in the thread.

    I'm wondering if this is a caching issue. Are you running any kind of server side caching? It might be servering up the pre-code page. Clear all your site caches then see if it works. You may also want to do a plugin conflict just to ensure nothing is blocking access. Sometimes security plugins can block access to automated services like Alexa, Yandex, etc.

    If it's still not working could you grant access? Then we can have a closer look :slight_smile:

    You can grant support access via WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back!

    All the best,
    Tyler

    • wadams92101

      Thanks Tyler, access granted ( I keep forgetting its on the site dashboard, not support on the wpmudev website). Anyway, I don't think its a caching issuce, since I cleared both the browser cache and the Sucuri cloud proxy cache. I don't have an on board caching plugin. Also, the problem is still there this morning, i.e., Alexa still won't verify. I was able to see the Alexa code / ID in "view source" in my browser. There is quite a bit of html in between the head tags so maybe that has something to do with it? Also there is a Yoast opening and closing comment and I was wondering if this was commenting-out the IDs?

  • Michael

    I personal use the Yoast SEO plugin myself.

    So you have signed up to those website right to claim ownership, such as:
    http://www.alexa.com/siteowners/claim

    Then gone to your Wordpress Admin > Yoast SEO > General > Webmaster Tools
    Copy your personal verification ID into the box and saved.
    (Note: This would just be the ID code without quotes or spaces around it, not the entire Meta tag, as it create that for you)

    Clear any web cache you might have too.

    Now go back over to Alexa and click on the “Verify my ID” button.

    That's "Method 2". If it doesn't work, use "Method 1" instead...

    Download the verification file from Alexa (and Google Webmaster, etc), then upload it into your web hosting home directory "public_html". They are just random text files with the code inside, you upload with a FTP client to your website root directory. Go back to the individual websites (Alexa, etc) to manually verify those file uploads, then ignore the Yoast SEO boxes in that case.

  • wadams92101

    Before I do that (which will be major take-down of my multisite and I've already cleared the Sucuri cache), can you take a look at the "view source" of my front page? The verification code is in there, so shouldn't the verifications work? Don't they crawl my site for the verification ID? If that's the way it works, is there anything you see in there that might be throwing off the robots? E.g. the Yoast comments? Or maybe there's too much in between the head tags?

  • Michael

    Just chipping in again to suggest something to check:

    So you see in your website header (when not logged in and within the header tags at top before the body):
    <meta name="alexaVerifyID" content="verification-id" />

    Where as "verification-id" would be something like: L7KXP8ysDqH4Q1rexM8SjI0nyaY
    (just a random example of how it should look, case-sensitive, no spaces, etc)

    That's all fine right?

    However, check the top line of code, is it the <!DOCTYPE> tag or a blank line before it?
    Can you access the sitemap.xml file and/or RSS feeds? RSS will give a "xml declaration not at start of external entity" error message, if this is the case.

    1.
    2. <!DOCTYPE html>

    With Wordpress themes or plugins, it's sometimes easy to add a little whitespace before PHP code. If that is the case, it places a blank line in your HTML code and the header sometimes doesn't get read correctly by some. You need to scan the code for that white space and remove it ( this can be finding a needle in haystack ) or use a white space fix ( such as wejnswpwhitespacefix.php ).

    Might not be the issue, but something to check as it can be overlooked and annoying to find.

  • wadams92101

    While deactivating and reactivating plugins to troubleshoot this problem, I got this warning when I reactivated the Yoast SEO plugin so maybe its the WPMUDev Dashboard that is causing the problem: -

    Warning!

    The plugin(s) might cause issues when used in conjunction with Yoast SEO.
    Both Yoast SEO and create OpenGraph output, which might make Facebook, Twitter, LinkedIn and other social networks use the wrong texts and images when your pages are being shared.
    Configure Yoast SEO's OpenGraph settings
    Recommended solution
    We recommend you deactivate and have another look at your Yoast SEO configuration using the button above.
    Deactivate

  • Tyler Postle

    Hey Wadams,

    I just tested this out on my own install with the Yoast SEO plugin and method 2 worked fine for me. I compared our verification meta tags and they are both the same - with the exception of the content id of course.

    So this means that it isn't able to read your site for some reason. My first guess would of been Sucuri like Anang mentioned, if we're hit with a captcha then that means alexa wouldn't be able to get through either. However, you mentioned you tested even with that deactivated and it still wasn't working? You might want to try deactivating all other plugins just to be sure if you haven't already. If that also doesn't work then I would give method 1 a try :slight_smile:

    Hope that helps! Let us know if you have any further questions.

    Cheers,
    Tyler

  • Tyler Postle

    Hey Wadams,

    Thanks for reporting back the solution :slight_smile:

    How important is the Alexa etc verification to SEO anyway? Do I have to choose between DDoS protection and Alexa verification?

    If you use method 1 then you may not need to turn off the DDoS protection as then the file would be outside of your WP install. Alternatively, you could whitelist the alexa bot IP. Here's a list of bot IP's: http://myip.ms/info/bots/Google_Bing_Yahoo_Facebook_etc_Bot_IP_Addresses.html

    I haven't actually tested those myself but don't see why they wouldn't be accurate still.

    Alexa Bot IP Addresses
    204.236.235.245, 75.101.186.145

    As for how important is Alexa verification to SEO - in my opinion it's pretty minimal, but I'm definitely not an SEO expert.

    Hope that helps!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.