Image and sidebar issues after running smush it

I ran smush it yesterday and now I am having several issues:
1. my right sidebar content/widgets do not show up
2. most of my images (i.e. those in a post or a page) are not visible to a customer
3. i tried a test page, adding in a new image, and this image does not show up either

I can see images and sidebar content from my wordpress interface, so they haven't totally disappeared.

I can't find anything to help me figure this out. And I need help desperately!

Thanks.

site: http://www.tennisessities.com

  • Tyler Postle

    Hey Rebecca,

    Hope you're doing well today and thanks for your question!

    Did you use our smush.it plugin on WordPress.org or the experimental version of smush.it pro we just posted in the forums? :slight_smile:

    Reason I ask is so I can test the correct one and it looks like you've removed it from your install. I've been using smush.it pro recently and haven't seen this behaviour yet. Did it happen right after doing a bulk smush?

    Look forward to hearing back Rebecca!

    All the best,
    Tyler

  • Rebecca

    Hi Tyler,

    I used WP Smush.It that I downloaded from the wordpress.org plug in site. Definitely did not use the pro version.

    I did remove Smush,It in a desperate attempt to negate the impact the bulk smush had on my site. (clearly that didn't work)

    Yes, this issue with the images and side bar happened right after I ran the bulk smush. I saw mentions of changing settings of some sort and issues with smush it and CDNs, but no answers or suggestions with any detail I could work with. I do have CDN enabled with WP Super Cache.

    I'm still kinda a newbie at all this stuff (6 months in), so REALLY appreciate any help here. I'm at a complete loss.

    Rebecca

  • Tyler Postle

    Hey Rebecca,

    Thanks for stopping my the chat :slight_smile:

    Can you send in your FTP and WP login? Then I will check the file permissisons.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Look forward to hearing back!

    Cheers,
    Tyler

  • Rebecca

    Hi Tyler,

    Progress! My images are now showing (details below) BUT, my right sidebar widgets still are not showing up.

    Images:

    first, I tried replacing the url in the CDN to my dedicated one, but that didn't change anything. I have now de-activated WP Super Cache, but that didn't seem to make a difference either.

    second, here is another thing I have noticed:
    on my "shop" page, the images do show up. Most are being pulled from elsewhere - i.e. all the t-shirts, etc. are being pulled from Zazzle. However, similar links in my posts do not show up (again, i can see them when using the wordpress interface, but not when I "preview" the post as a site visitor would).

    third, you had suggested i try de-activating some of my other plug ins to see what happened. I deactivated BJ Lazy Load and voila, all my images were visible again!!!!!!!!

    So....how can i get my sidebar widgets to be visible again?

    (Note that I am planning to join either the 10 am or 2:45 pm live sessions tomorrow unless you can help me via this route today.)

    Thanks,

    Rebecca

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.