Image link returns 500 Error

I am getting a "500 Internal Server Error" when trying to access any image located in this path "wp-content>uploads>wpall*****>files"

Also, I am using "Chrome Book" SFTP client and I'm getting "authentication failed" each time I try to connect to the server.

  • Adam Czajczyk
    • Support Gorilla

    Hello Russell

    I hope you're well today and thank you for your question!

    I am getting a "500 Internal Server Error" when trying to access any image located in this path "wp-content>uploads>wpall*****>files"

    It seems to be an issue with some internal nginx (webserver) rules on our hosting, related to presence of the "files" folder inside "uploads". Our sysadmins are looking into it so hopefully they'll be able to sort that out soon.

    Also, I am using "Chrome Book" SFTP client and I'm getting "authentication failed" each time I try to connect to the server.

    We're not blocking the connection on our side. We've tested it and were able to connect (using different machines/FTP clients/geographical locations), our sysadmins didn't find any issues on our end related to it.

    I think this might be related to some firewall settings either on your Chromebook or your internet provider's end. Have you tried to connect form a different machine just to check for your self?

    I'd also suggest checking firewall settings anyway - as far as I understand Chrome OS has a built-in firewall that seems to be quite strict. Take a look here, please:

    https://forums.tomsguide.com/faq/how-to-configure-firewall-settings-in-chromebook.27663/

    Usually in a firewall app there's also an option to white-list certain IP addresses so in this case you would want to white-list your WPMU DEV Host IP (you'll find it in the Hosting section of The Hub for your website - it's the same IP that you'd use for DNS A record for your domain).

    Best regards,
    Adam

  • Russell
    • Flash Drive

    Hi,
    Do we have any news on this...

    It seems to be an issue with some internal nginx (webserver) rules on our hosting, related to presence of the "files" folder inside "uploads". Our sysadmins are looking into it so hopefully they'll be able to sort that out soon.

    Russ

  • Adam Czajczyk
    • Support Gorilla

    Hello Russell

    Thank you for your response!

    While I can confirm that the main related issue (the one that I mentioned previously) is already solved, I checked this particular one again and found out that there's also a different aspect involved. The images are actually there and... are available. If you try to access this URL

    yoursite.com/wp-content/uploads/wpallimport/files/18250403210F.JPG

    you'll get "not found" message but try the same this way

    yoursite.com/wp-content/uploads/wpallimport/files/18250403210F.jpg

    and the image will load.

    I didn't notice that before (I'm sorry about that) but you're using uppercase characters while file names are using lowercase letters for extensions. This is a difference and not only on our hosting but on most *nix (linux/unix) powered hosts as the file system (unlike for example windows) does see e.g. "image.JPG", "IMAGE.JPG", "IMAGE.jpg" and "image.jpg" as four different images.

    It's related to file system specifics and is not a bug. It's also the same for example on other hosts that I use for my testing sites, that are not related to our (WPMU DEV) hosting in any way.

    While it might make no difference on a local device (for sure not Windows, I'm not sure about Chrome OS but I suppose it's the same), it's very important to use upper/lower case characters anywhere on site/in site source code correctly, exactly as it's used in file names. In case of these images either renaming image files to use "jpg" extension instead of "JPG" or replacing "JPG with 'jpg" in URLs on site would solve the issue.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.