Images are blurry on product pages

With CDN enabled images on products are looking blurry, while the "automatic resizing of my images" or "WebP conversion" are deactivated, the images are still blurry. With no CDN, images are good quality.

  • Nithin
    • Support Wizard

    Hi Steve McGough,

    I gave a closer look at your website and could notice the issue. I'm checking with our developer to see what could be causing such anomalies, will keep you posted once I get further feedback regarding the status of the issue asap.

    Also please do note that the CDN bandwidth limit has reached its allowed bandwidth limit, you can upgrade the limit via the Accounts Page if needed:
    https://premium.wpmudev.org/hub/account/#hub-my-account-add-ons

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Steve McGough,

    On giving a closer look, the issue is more related to the Automatic Resizing option enabled in the Smush CDN side, because of the containers in the product pages need to have a larger image, the resize setting is serving an image smaller than the container width.

    Easiest would be to set the Automatic Resizing option as disabled. I have disabled the "Automatic Resizing" option and cleared the WP Rocket cache, and the images aren't blurry any more.

    Could you please check, and let us know if you still notice any issues regarding this. So that we could give a closer look if needed.

    Kind Regards,
    Nithin

  • Steve McGough
    • Design Lord, Child of Thor

    OK. But it seems like the images are still blurry until I go in and refresh the page. This is happening when I open products within a Chrome incognito window. When I refresh the image, it's not blurry.
    So we did the Rocket cache clear for the local server, but how do we get Smush Pro CDN to refresh all of their images?
    When we turn off the Smush CDN, the images are all fine. So is there a way to clear the cache and refresh on the Smush CDN side?
    Steve

  • Nithin
    • Support Wizard

    Hi Steve McGough,

    I could notice the issue, it seems like when loading the page for the 1st time the images are blurred, and refreshing it works fine. It does take some time to notice this behaviour too.

    This is odd behaviour. Smush CDN shouldn't cache, and it should have automatically served the images without any issue.

    I checked the source of the images loaded, and it looks fine. In general, the images blur because the container width of the theme is bigger than the image. Are you comfortable with us temporarily disabling the WP Rocket Cache plugin, to see how the Smush CDN behaves too?

    I'll also have to bring this into our developer's attention again, to see what could be done to help get this sorted. Will keep you updated once I get further feedback asap. Have a nice day ahead.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Steve McGough,

    Terribly sorry for the delay in getting back to you. Yes, could notice deactivating WP Rocket seems to cause the same issue, and even when Smush CDN Is deactivating it's causing the same issue.

    On giving a closer look, the theme is loading an image smaller than the container of the images, and hence appearing blurred.

    Could notice the size of the images loaded seems to be around 200px X 200px in width and hence causing this. On giving a closer look, I could find you have the configured Main Image Width, ie the images loading in single product pages to load in 200px of width, when the container width is around 384px.

    For example, the images link loaded are:

    https://yourwebsiteURL.com/wp-content/uploads/2018/12/grayguns-hk-reduced-reset-kit-p30-p2000-nts-101-200x200.jpg
    https://yourwebsiteURL.com/wp-content/uploads/2018/12/grayguns-hk-reduced-reset-kit-p30-p2000-nts-102-200x200.jpg

    Maybe you could update only Main Image Width value to 384px, and then go to WooCommerce > Status > Tools in the plugin side, and click the "Regenerate" button for the "Regenerate shop thumbnails" option, and check whether it resolves the issue?

    Please do note that regenerating thumbnails can break the images in some cases, so would highly recommend you to take a backup before making any such changes in your website, so that you could revert back if needed.

    Please do let us know how that goes so that we could give a closer look if needed. Have a nice day ahead.

    Kind Regards,
    Nithin

  • Steve McGough
    • Design Lord, Child of Thor

    Thank you for the information. I did some digging under Customize > WooCommerce > Product Images and found they were set to 200x200. So I figured I would start there. I increased the size and then regenerated the images as you suggested under WC > Status > Tools.

    I think they look a lot better.

    Thank you for your patience on this. Much appreciated.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.