Images are stacking Vertically in activity stream

I have an issue with the images in activity stream as you can see on my site. The images appear vertically instead of next to each other. I have tried the solution discussed about this issue here but it didn’t work for me. The thumbnails got broken and still not in correct position. Any help on this is appreciated. Please see

  • ThePath
    • The Bug Hunter

    Hi Giorgos,

    There is no styling to tell them to go horizontally, i.e. no float attribute.

    Can you not just add styles to these images to make them do what you want i.e

    .activity-content img{ float:left; margin:0 15px 15px 0;}

    Or something similar?


  • aecnu
    • WP Unicorn

    Greetings giorgos,

    Thank you for this great question and a significant item to bring up.

    As ThePath has indicated this is certainly a styling issue probably inherited from your theme and ThePath has indeed given a clue to styling that may resolve the issue.

    Please advise.

    Cheers, Joe

  • giorgos
    • Design Lord, Child of Thor

    Thanks Gents, Indeed ThePath is correct. But now the images are lining up diagonally.

    My css expertise are limited. Do you know what additional css code is needed in order to be horizontal? I tried several variations my self and haven’t found the solution.

  • ThePath
    • The Bug Hunter

    OK try this:

    .bpfb_images a {
    display: inline-block;
    float: left;
    margin: 0 15px 15px 0;

    Take out other CSS from earlier.

    And if you open the activity stream template or whatever handles that section take out all the
    tags that are above every image, they are not required and seem to be pushing the images down a bit.

    Hope that helps

  • ThePath
    • The Bug Hunter

    No problemo.

    Yeh those damn br tags get everywhere. I hardly ever use them in my themes as you can attain the same results with good CSS.

    So check all the templates regarding the activity stream, you find this leads you into a functions file that deals with the images and bundles in the br tags…

    I’ll mark this as resolved.

  • PeterHatch
    • WPMU DEV Initiate

    If anyone is still looking for a fix to this 2 years on I found setting thumbnails to 150 wide and putting this in theme css works for me

    a.thickbox {
    display: inline-block;
    float: left;
    margin: 0 5px 5px 0;
    .bpfb_images br {
    display: none!important;

    div.thickbox {
    max-width: 176px!important;
    max-height: 176px!important;
    margin-bottom: 10px!important;
    margin-right: 10px!important;

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.