Images doesnt show

Hi,
On my website sometimes show the images right but sometimes doesn't show.

There is any chance to take a look or give some advice?

This happen in one more website where I have the WPMUDEV instaled.

  • Adam Czajczyk
    • Support Gorilla

    Hi ferreirex

    I hope you're fine today!

    I think this is mostly related to two things together:

    1) The "insecure parts of the site" that you raised in your other ticket here:

    https://premium.wpmudev.org/forums/topic/something-doesnt-work-well-in-ssl/

    I have already responded to you there but I just realized that my response wasn't quite "complete" so let me add up to it:

    the reason for that "insecure" warning is the fact that some images are included using "http://" URL prefix which breaks SSL. Changing the prefix to "https://" for these images URLs should help;

    However, since these images are fetched from a different domain that even with "https://" prefix they still might be missing due to so called CORS policy, which is, basically, a way to prevent "injection of foreign content" into secure site - for security reasons, of course.

    Taking that into account, I would strongly recommend using images hosted locally on the site. Then some "offload" plugin or CDN could be used to improve these images performance.

    2) It seems that site's currently have Hummingbird's Asset Optimization enabled. I suppose there's also some caching enabled. In that case after dealing with above issue, I think it'd be best to clear entire Hummingbird's cache by going to "Hummingbird -> Dashboard" page and clicking on "Clear cache" button there. This should help "regenerate assets" after any changes that already were made and that will be made to address first issue.

    If that still doesn't help, let me know and please enable support access to the site so I could check it. To enable support access, please go to the "Network Admin -> WPMU DEV -> Support -> Support Access" page and click on "Grant Support Access" button there.

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hi ferreirex

    I have tried to turn on the CDN on Smush Pro, but it is saying I need Upgrade my account and I don't get that.

    The only requirement to be able to enable Smush CDN, if you are WPMU DEV Member - and you are, is to keep WPMU DEV Dashboard plugin active and logged in into your account. Sometimes though the Smush API Key may need update.

    There's an "Update API Status" button for this on "Smush Pro -> Settings" page. I just accessed your site, click on it and after that the CDN got activated so that's fine now.

    However, while some images are now served from Smush CDN, this won't fix the issues with images not being loaded due to Mixed Content and/or CORS errors. You still have images that are added to the site from some external URL (in addition - over HTTP instead of HTTPS). Is there any reason for this?

    Those images seem to be part of layout so why not just download them, upload to a Media Library on this site and use from there? Is there any reason for that?

    Doing that should solve these issues instantly and it doesn't really seem to be case of too many/too heavy images for the site to handle :wink:

    Best regards,
    Adam

  • ferreirex
    • Site Builder, Child of Zeus

    Hi Adam Czajczyk

    Thanks for the answer, thanks for the CDN I dont know that "Update API Status".

    About the images I have asked for the theme developer to know is he can do something about that.

    About the icons is the most urgent thing for me, I have past a image where the icon should show.

  • Predrag Dubajic
    • Support

    Hi ferreirex,

    It seems that the issue here is with icomoon fonts CSS overwriting the CSS for fonts in your theme.
    After the page is loaded it then loads this CSS, probably via JS:
    https://i.icomoon.io/public/f9a8001194/Surveyemojies/style.css
    And that file has the CSS to apply ivory-icons font to .icon class, and in addition to it being loaded at the end it also uses !important in the code so it completely overwrites the IcoMoon font that your icons use.

    I have overwritten that font CSS by going to Appearance > Customize > Additional CSS and added this code in there:

    body .icon {
    	font-family: 'ivory-icons'!important;
    }

    So the icons are shown properly now but I'm not sure where that icomoon font is used on your site and if my code will affect some of the other icons on your site.
    I would suggest discussing this with the theme developers to see why the both fonts are loaded and applied on the same class so that they overlap with eachother.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.