Images in Network theme boxes

I haven't seen a definitive answer to this issue so far...

With WP 3.1 The Featured image option no longer seems available in the advanced options for an image within a post, and in earlier versions the only way to make an image appear in the front page image box using Network was to mark an image in this way (except having a default image set with may no be suitable).

I've seen passing mention that just having an image within a post will enabled it to be featured in this way, but with much testing I've not seen that happen.

It seems with 3.1 you get just a 'one shot' chance to set an image as featured, and you cannot retrospectively select an image as featured, which would be the real world case use.

So how do you make an image 'featured' and if that's not required how does it appear in the box?


ps Sorry to have become such a regular!

  • DavidM

    Hello Tim,

    I've just tested that scenario on a site and it worked just fine. Basically, I had an existing post recently made that had no Featured Image attached to it. I edited the post, included a Featured Image and updated it. I took a look at the main site and there was the Featured Image! :slight_smile:

    So it worked in my test case. Have you had trouble with this though? Perhaps we can try and find out why it wouldn't work in your case, if so.


  • Tim Watt

    Thanks Tim, but I'm afraid that makes no difference.

    I hope WPMUDEV appreciate my candour here (and it's nothing personal as it's several at other times over several weeks) but I really think there's a general communications issue here. As clearly as I could I tried to describe my issue but the response is largely as waste of typing as it clearly reveals that my question has really not been read properly.

    So can I try with pictures.....

    In 3.0 "Featured image" can be set at the bottom right of the dashboard for each post. See here.

    Whereas in 3.1 for that option is missing and there appears to be no other way to set "Featured Image" which is essential for Network. See: here.

    Clearly there's awareness that this has been asked before since there's a video been posted by WPMUDEV on how to do this - BUT I haven't been able to view this (or embed) because there is a coding error in the API (Jeess... frustration upon, frustration.....)....

    So how do you make "Featured Image" be an option somewhere?

  • Timothy Bowers

    Ah... Well I don't work here so you will have to excuse me for "not reading properly", I simply tried to help as another user, I re-read your post again though and came to conclusion that first time round it wasn't written as clear as you believe. Two people made the same mistake in reading your post which is why there is an option for uploading images, it allows for screen shots to save any confusion.

    I understand it can be stressful though, I'm going bald ripping hair our as well (lol), the problem with forums is that text can always be misconstrued. :slight_frown:

    From using Google I see this is maybe a WordPress issue, top of the admin page should be a tab "Screen Options" click on and that and see if the option for "Featured" is there and if so is it checked? If not then check it.

    I looked another install of mine which I just upgraded and noticed that it doesn't have the featured option there which I need to investigate later. But for now, other suggestions:

    Suggested by Andrea_R over on WP:

    On multisite, if you do not enable the IMAGE UPLOADS, under Network admin -> Settings, then .... well, that kind precludes having featured images.

    Tick that box. Save.

    Featured images show up on the screen options tab.

    Looking at our friend Google, there maybe other causes for this well.

    Some themes do indeed allow you to take the first image in a post and use that as featured, but not all do. This is entirely down to what the designer and developer implemented in their code.

    I hope this time I was of some help. :slight_smile:

  • Tim Watt

    Sorry Tim, I wasn't referring to you at all in my comment.... I'm entirely grateful.

    Anyway, I found a way round in that featured images does appear as an options if you chose the Upload from your computer option. I host most stuff in the cloud (see above - attachments as on this forum seems so dated) but I suppose almost all my users will be uploading from office PCs. (BTW the screen options doesn't include the Featured image as a choice).

    I worked out how to delete the buttons but haven't worked out how to remove the "Join Now" button (my main site is by invitation only). I tried removing the code from the branding-header.php file without success (other than breaking the page!). That would be nice to fix.

    However, what's causing me to pull hair now is that the links in the home featured posts boxes POINT TO THE WRONG POSTS - or rather all but one of the four point to the wrong post. Really, that's a killer if I can't find a fix for that!

    Test site is at:

    Grateful for any help, but rather expectant as far as WPMUDEV are concerned...


  • DavidM

    Thanks for mentioning that Tim. And yeah, I seem to have missed the original point as well. On my test site, I have the Featured Images and that is why in my test site I was able to set them and see them in the Network theme. I was unaware that the option would be missing in some WordPress 3.1 setups though.

    Tim Watt, if you could look into setting that network option that the other Tim posted, perhaps that will resolve the issue?


  • Timothy Bowers

    Wrong Post Links - Fix

    Ah just noticed that issue now, ok so here is how you fix the linking issue.

    Open /wp-content/themes/network/library/functions/custom-functions.php

    Around line 428 you will see:

    foreach ($thisposts as $thispost) {
    			$thispermalink = get_permalink($thisposts->ID);
    					if ($homepage_show_thumbnails == "yes") { 

    It should look like this:

    foreach ($thisposts as $thispost) {
    			$thispermalink = get_permalink($thispost->ID);
    					if ($homepage_show_thumbnails == "yes") { 

    Notice the 1 character difference at this part $thispost->ID

    I don't believe this will cause other issues, but it does fix the incorrect linking issue.

  • Timothy Bowers

    Oh sorry, you wanted to remove the sign up button as well?

    Open /wp-content/themes/network/library/components/branding-header.php

    Near the bottom remove this:

    <?php if ( !is_user_logged_in() ) { ?>
    			<?php signup_button(); ?>
    		<?php } ?>

    The code there basically says if the user is not logged in then show the signup_button().

    I can give a postal address for cigars to be sent into! :wink: lol

  • Tim Watt

    Hi Sorry to raise this from the apparent grave - but this issue is still live in the form raised by other Tim.

    I found that the show featured image issue is OK with my production instal of WP 3.1 but I do get the issue where the reference to the inline image for the thumbnail is incorrect.

    This happens when featured image and when you use a default thumbnail image (with I think will be my preferred solution).

    So, I get the broken image sign and if I follow the link get the following error:
    file not found files/2010/10/1314_Hawthorn_panels1_Porches_front.jpg
    Query String : src=
    TimThumb version : 1.19

    That image url is correct but obviously something's preventing it showing.

    I tried Tim's UTC suggestion to no effect and the second hack didn't seem worth trying as that was suggested for Network posts only while my sites would feature blog posts.

    Any suggestion of a proper fix for this?



  • Tim Watt

    It's a shame not to have a fix to make the tinthumb functions actually work. Here's where I'm at with this....

    Set featured image doesn't work due to something wrong with timthumb.php - I've compared with other suggested fixes but the provided timthumb file doesn't match the suggested fixes on these forums for earlier versions of WP.
    A fix suggested is to edit files to make the first image posted show.... mmmm not sure about that solution yet.
    A solution but is working (but may not scale well on large network) is the "Default Thumbnail Image URL" option, each of which would need to be re-sized.

    TimThumb is supposed to re-size images and if working would be best. Even better if the Default Thumbnail Image URL worked unless over-ridden by a Featured image....

    Hopeing someone can save me many hours of finger work here.... if only TimThumb worked....


  • Timothy Bowers

    Still having issues with the timthumb?

    I found that the show featured image issue is OK with my production instal of WP 3.1 but I do get the issue where the reference to the inline image for the thumbnail is incorrect.

    I'm confused by your statement here, so just to clarify are you saying it works on your production install but not another install?

    Anyway some other things to consider, not sure if they would be an issue here but have you checked for permission issues? Are the images on the same server?

  • Tim Watt

    Hi Tim

    Sorry at my imprecision but it's very annoying to have these repeated issues...

    The issue is in my production site - otherwise all working.

    Currently, I've chose to use Default Thumbnail Image URL option for each blog - which is fine for the top level site but each blogger might get tired at having the same image for every post so I should move to using the featured image (or some similar) solution instead soon as poss.

    Re-sizing images was a snap using Automator but it took some time identifying a suitable image for a network of over 100 blogs.

    As I said this does not work, with no image displayed (no inline image), with an error message when I follow the linked image as above. So it appears to be a TimThumb issue.

    Suggestions tried: your UTC suggestion; changing the permissions of the enclosing folder from 755 to 777 and back.

    The images are on the same server, plus I see Flickr is allowed.

    Suggestions not tried: The TimThumb file doesn't match much of previous discussions so though best to leave - plus another form poster has tired attaching a zip file for his solution and has not been allowed to do this it seems. This same person also posted a complex list of changes to get this to work for network posts. There is also much on Google (which may itself be out of date) saying timthumb has not been updated for WPMU. also the version of timthumb with the theme isn't the newest but seems to be customised so I thought best ask for advice here....

  • Timothy Bowers

    Well I'm not sure how customised it is to be be honest. I'm not a huge fan of it to be honest, I had other issues with this in different themes not relating to WPMUDEV.

    Depending on how messy you want to get you could consider trying alternatives:

    I quote wpCanyonThemes "No Damn Timthumb".

    I could have also sworn I saw something in the WP Trac which detailed a function to handle thumbnails. Can't seem to located it now, but I originally came across it looking for better options than Timthumb when I had issues with other themes.

  • Tim Watt

    Sounds great but let me update on progress....

    My production site is now running using Network: see

    Images are correctly being resized and dislplayed at the top layer (admin) blog which features Network posts. This is achieved only by changing images to 'Featured image' - which is a pain as my users are not familiar with Wordpress and don't really wont to be.

    They've managed to upload images fine, so, ideally, to enable the site to be self-managed, the first image or featured image should automatically be featured.

    The issue remains less satisfactory with each user blog. Featured images (the same as above, less satisfactory that inserted images) are not displayed in posts that are on 'Blog posts' setting. I've had to manually set each blog to a fixed featured image URL (so far only the most active as this very labour intensive).

    The crucial difference seems to be from testing that whether the setting is blog posts or network posts appears irrelevant but there must be some error in the coding to do with the blog level as for the top level blog these thumbs work but not for the subdomain blogs.

    This is now more urgent as the site is being updated by bloggers and although each post looks fine and the top level site looks fine, each user's blog has a broken image up front and no way for it to be fixed!

    Thanks, Tim

  • Timothy Bowers

    The crucial difference seems to be from testing that whether the setting is blog posts or network posts appears irrelevant

    This might be something to bring to the designers attention as this would seem to be a bug in the actual theme. It would seem a redundant feature for people making blogs on your site. But this could be intentional for those people creating a network of their own sites? Tammie would be the best to comment here.

    I'm not sure without looking at the code whether the theme takes the first image or not, I know some themes from other developers will only take a "feature image" some themes I've come across before require the addition of a custom field... I seem to recall (bad memory, so could be wrong) asking something about this in one of my first posts here the other day, I'll have a look back... :slight_smile:

    I'm busy over the weekend, but will try to find time to look my set and the code. If Tammie sees this first I'm sure she will comment on the default behaviour of the theme.