Images not showing as optimized in Google Page Speed

Google Page Speed showing images need compressing for live site. But in Staging site, the Google Page Speed shows all the images as optimized.

Not able to notice any difference in both the site.
Live site: athlxxxxxxx.com

Support access enabled.

Note: Do not make any changes in the website without checking it out with the member.

  • Sajid

    Hello Traci,
    Hope you are doing good today :slight_smile:

    Yes, I can see the same images but I also noticed that you have not enabled Include my original full-size images in WP Smush settings on your live site (as well as on staging).

    That means, you have not optimized the full sized original images, yet. So in order to move forward, please go to WP Dashboard -> Media -> WP Smush -> Settings, enable Include my original full-size images and save settings. If it does not update, then click on RE-CHECK IMAGES blue button on right side of the stats column. Once you see some images to be smush, then click on bulk smush again.

    Also, I recommend you take backup of your original images before smushing original images.

    Once you have all images smushed, then scan the site again on Google Page speeds or better use Hummingbird plugin to do all this right from your site's Dashboard. This also have other cools features like minification, browser cache and gzip compression that help you increase the site performance.

    Take care and look forward towards your response :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • Traci

    Hello Sajid,

    Include my original full-size images in WP Smush settings was enabled already on staging site and I thought I had enabled on live but it wasn't. I enabled it on the live site and when I clicked on re-check images the message was "all images are optimized". The 25 images from the live site are still coming up in page speed as needing to be optimized.
    I don't want to use Hummingbird until i know why some images are being optimized.

    Thanks,
    Traci

  • Denitsa

    Hey Traci,

    I can see you have a different number of images between your testing and live environment. I also saw that you didn't have Super mush my images on and this would most likely improve your optimization score, so will you try this out and come back with the results here (I don't want to touch anything on your live site without your consent and the images are different so I can't use the staging one to test that).

    Looking forward to hearing back from you!

    Warm regards,
    Denitsa