Images on blog not showing on Firefox

First, the issue was that SSL was not working on the site, after activating a plugin to fix SSL URL's then it worked the issue was when trying to check images from the blog on Firefox which are not displaying.

After running a conflict test, the same issue happened.

Thanks in advance!

  • Predrag Dubajic
    • Support

    Hi Sarah,

    I did some extensive tests and it seems that the issue is specific to Firefox working on specific screen sizes, and it looks like it's something specific to your site.
    I tried using Divi and Image Zoom Module on my test site but I had no issues with images there.

    When I inspect the broken image on your site it says in the console "Couldn't load image" but when I open the link of that image in a separate tab it loads fine.

    Could you try performing a conflict test by disabling your other plugins and see if the issue is gone after that?
    There shouldn't be the need to test with the theme because during the tests on my end I was using Divi already.
    This should help us pinpoint the cause so we can debug it further.

    Let us know how it goes.

    Best regards,
    Predrag

  • Sarah
    • New Recruit

    Hello,

    Thank you for the reply. The last person from your support team already did an extensive test of the plugins. He went through each one, turning off and back on. Do you have the notes from that live chat between him and I? It was after this that he escalated the problem to ticket status.

  • Adam Czajczyk
    • Support Gorilla

    Hi Sarah

    I did more testing on your site and my end and apparently the issue is not limited to Firefox only. It also happens in Chrome and any other browser - it's only easier to spot in Firefox because, unlike Chrome, Firefox shows "empty boxes" in place of missing images. Chrome simply ignores them and shows "nothing" (so it looks like it's working and it's easy to "miss missing images" if there's more of them).

    However, it is indeed related to the screen size. With "regular desktop" issue doesn't happen but with "responsive views" it does. I did some testing but I must admit I wasn't able to drill down to the "core" of the issue.

    Therefore, I've asked our developers for help so I passed all the information to them along with access credentials and they'll investigate it further.

    Please keep an eye on this ticket and we'll update you as soon as we get to know more about what (and why) is happening and how to fix that.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.