Images on front page not showing up after i go live

Hi,
I have Network working great on my production site (localhost, MAMP) but when i pushed the theme folder to the live site, the featured images for the posts are no longer showing -- is there somewhere that I need to change things? I am ok with coding, etc.
I created new posts, so i am not trying to pull post info from my test environment.
Thoughts?
Thanks!

  • cmccb
    • Design Lord, Child of Thor

    I want to give the live link but am in production for a client -- any other option? I really need to fix this, and am flummoxed as to where I am going wrong -- I am using set featured image, the images are going to the appropriate directory, but they just won't pop up on the front page of network like they do on my local install. I triple checked my settings, and even tried a fresh install of network, and still no luck.
    argh.

  • Philip John
    • DEV MAN’s Apprentice

    Hiya!

    Are your production and development installs completely identical? Have you simple copied all the files and database over to the production server?

    If not there's likely just something different like images not registered in the database or stored in the wrong place etc

    Phil

  • cmccb
    • Design Lord, Child of Thor

    Here is my .htaccess file (attached)

    Also, images are being uploaded into blogs.dir/2/files/2011/08/image.jpg -- this is when I create a new post, and add featured image. There is a cache folder there, and it is empty.

    The way I set this up was to create the full working network on my local install - which worked great. When I went live, I installed a fresh copy of wordpress, created a new database on the server, and then uploaded my child themes and the parent themes from my test sites. I was initially thinking that it could be that the copy of network that I had was corrupt (or I did something awful to it), so I took it down from the server, and uploaded a completely clean copy of network from wpmudev, only to have the same issue. ( Also, I disabled the single plugin that I have installed to date, which is custom fields template, and that did not help.)

    On my test server, I would create a new post in the sub-blog, and set featured image and that image would be recognized by the main blog as it is supposed to be.

    I have also included the "view source" text from both sites as an attachment.

    The image is being displayed in safari as an empty box with the "?" icon in it and on firefox not at all (the text is moved up as if it does not exist).

    Thanks in advance for all the help - cmccb

  • Philip John
    • DEV MAN’s Apprentice

    Are you using any form of caching at all?

    Problem here is you're never going to get exactly the same results on production as test unless you have *exactly* the same set up, which includes copying the database over.

    There are numerous options with the theme that won't be on your production site unless you copy the database and/or re-apply the same settings.

    Phil

  • cmccb
    • Design Lord, Child of Thor

    Thanks for your quick response. I do not have any caching set up.

    I did not want to copy the database over since I had so many test posts, and had installed and uninstalled so many plugins that I was testing...perhaps that was not the best way to go about it.

    Do I set up caching via a plugin or through cpanel? (yes I am not as advanced as I wish I was!)
    cmccb

  • cmccb
    • Design Lord, Child of Thor

    will install wp super cache, and hope that it solves my image problem - though, i am not sure that it will after reading up on it all. i mean, i have a very bare-bones site right now with hardly any data....just want those images to show :slight_frown:
    cmccb

  • cmccb
    • Design Lord, Child of Thor

    Hi, just more info as I troubleshoot here. Maybe it will help?
    I used firebug and when I hover over this, it says, "failed to load given url". The image does exist in the directory, and it displays on the sub-blog in the post. I have set it as featured image.

    li class="withthumb" style="display: list-item;">
    <img style="width:227px; height: 108px;" alt="" src="http://ABCD.com/wp-content/themes/network/library/functions/timthumb.php?src=/blogs.dir/2/files/2011/08/star.jpg&h=108&w=227&zc=1&multisite=true&blogdirid=2">
    <h2>

  • cmccb
    • Design Lord, Child of Thor

    GD Library Error: imagecreatetruecolor does not exist - please contact your webhost and ask them to install the GD library
    Query String : src=/blogs.dir/2/files/2011/08/littlestar.jpg&h=108&w=227&zc=1&multisite=true&blogdirid=2
    TimThumb version : 1.19

    this is what I get when I try to go to that URL.

  • cmccb
    • Design Lord, Child of Thor

    Update: my admin folks enabled GD library for me; now my posts won't show - permalink structure is screwed up....
    http://*.ABCD.com/2011/08/65/

    instead of

    http://*.ABCD.com/2011/08/little-star/

    and...images still are not being pulled, even though i created a new post on subblog.

    I feel like I fell down a rabbit-hole :slight_frown:

  • Philip John
    • DEV MAN’s Apprentice

    Let's start from the beginning... It sounds like you're trying to replicate your test site from scratch on your production server, yes?

    However, as you've been doing a lot of testing locally there are bound to be differences. Therefore, have you tried doing a "dummy run" by re-creating your test site locally first?

    That's worth a try as you'll be able to do a test of moving the site live....

    Phil

  • cmccb
    • Design Lord, Child of Thor

    Well,

    I pinged my sys admin guys. They did some magic/ told me about wordpress multisite installs requiring more memory/ now everything works. Miracle! (for now :slight_smile:

    Thanks for the support here - you guys are great. Looks like it was NOT a theme issue. Am getting my images pulled, and no errors showing up.

    cmccb

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.