Images require reloading to appear

Hi
This is a relatively new problem.
My site takes unusually long to load than it used to and images won't load unless I refresh the page. I'm not sure what is causing the slow down so I've tried removing a few things from the site that I thought could have been the culprit (Images and gif files).
It loads slightly faster but images won't load until I refresh the page at least once.

Can anyone help me with this issue?

Many thanks,
Michael

  • Adam Czajczyk

    Hello Michael

    I hope you're well today and thank you for your question!

    I have visited your site using Chrome and Firefox browsers and in both cases it loaded reasonably fast and the images on homepage were there from the start (no need to reload).

    Does this mean that you managed to solve the issue or "is it just me"?

    If "its just me", tell me please:

    - what browser(s) did you test that with and under what OS (including version numbers)
    - do you have any browser extensions/add-ons active and if so, did you try to disable them temporarily?
    - did you try in browser incognito mode, if so, does it also happen then?

    If you're still experiencing the issue, please answer these questions and also enable support access to the site so I could take a closer look at it. To do this, please go to the "WPMU DEV -> Support" page in your site's back-end and click on "Grant Support Access" button there.

    Kind regards,
    Adam

  • Michael

    Hey Adam,

    Thanks for the quick reply.

    Sorry, I should have elaborated a bit more. The home page is loading images fine, it's only when I click onto a project that those images won't load.

    I got a few friends to try who use different browsers and everyone was having the same issue. I have given incognito a try and that doesn't solve it either.

    I've just granted you access so feel free to take a look!

    Thanks again Adam.

  • Adam Czajczyk

    Hello Michael

    Thank you for the explanation, I could see the issue now :slight_smile:

    I have checked the site and made following changes:

    1. On "Settings -> General" page I have switched off an Endurance Cache (set it to "Off (Level 0)"); that's because you already got W3 Total Cache on site and that might cause some unexpected and hard to diagnose issues in long term.

    2. On "Appearance -> Customize -> General" page I switched off the "AJAX Powered" option as this was what seemed to be also related.

    After clearing W3 TC cache I checked the site again with Firefox and Chrome, both in regular and incognito mode and it seems to be working fine now - the images are loaded upon first page load.

    I hope that helps :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.