Images showing as blank on Multisite Sub-domain

We have two subdomains set up on a Multisite format. When I try to upload images into the Media Library, they appear to be loading, but then they only show up as a blank box in the library. I have tried to load on both of our subdomains (northcentral.ksvype.com and southcentral.ksvype.com).

Is there I a change I need to make somewhere in the settings for the images to load correctly. The images are only 512x512 and 38kb in size.

  • Ash
    • WordPress Hacker

    Hello David

    It looks like there is an error. Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    Also, would you please enable support access so that I can check, if needed? Please follow this article to enable support access: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Have a nice day!

    Cheers,
    Ash

  • David
    • Flash Drive

    I have enabled WPMU support on the site ksvype.com.

    These are the errors I got when I set the debug mode. I have now turned off debug mode.

    [02-Jul-2019 16:00:31 UTC] PHP Notice: Undefined index: adsanity_show_in_content in /home/g7ag5gkzldlz/public_html/ksvype.com/wp-content/plugins/adsanity/lib/automatic-inclusion.php on line 209
    [02-Jul-2019 16:00:40 UTC] PHP Notice: Trying to get property 'ID' of non-object in /home/g7ag5gkzldlz/public_html/ksvype.com/wp-content/themes/gameday/functions.php on line 1261
    [02-Jul-2019 16:00:40 UTC] PHP Notice: Trying to get property 'ID' of non-object in /home/g7ag5gkzldlz/public_html/ksvype.com/wp-content/themes/gameday/functions.php on line 1261
    [02-Jul-2019 16:00:41 UTC] PHP Notice: Trying to get property 'ID' of non-object in /home/g7ag5gkzldlz/public_html/ksvype.com/wp-content/themes/gameday/functions.php on line 1261
    [02-Jul-2019 16:00:41 UTC] PHP Notice: Trying to get property 'ID' of non-object in /home/g7ag5gkzldlz/public_html/ksvype.com/wp-content/themes/gameday/functions.php on line 1261
    [02-Jul-2019 16:00:41 UTC] PHP Notice: Trying to get property 'ID' of non-object in /home/g7ag5gkzldlz/public_html/ksvype.com/wp-content/themes/gameday/functions.php on line 1261
    [02-Jul-2019 16:00:43 UTC] PHP Notice: Undefined index: adsanity_show_in_content in /home/g7ag5gkzldlz/public_html/ksvype.com/wp-content/plugins/adsanity/lib/automatic-inclusion.php on line 209
    [02-Jul-2019 16:01:14 UTC] PHP Notice: Trying to get property 'ID' of non-object in /home/g7ag5gkzldlz/public_html/ksvype.com/wp-content/themes/gameday/functions.php on line 1261

  • Ash
    • WordPress Hacker

    Hi there

    Those errors are not anything significant, so you can ignore those.

    Now I think this could happen due to a plugin or theme conflict. Would you please run a conflict test? Please deactivate all plugins except this one and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. You need to do the same with themes as well.

    You can find the flowchart here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-1

    Please let us know how it goes. Have a nice day!

    Cheers,
    Ash

  • David
    • Flash Drive

    Ash: I did the plugin and theme test before I logged this support ticket. I actually did five or six different ones.

    I changed to the default WordPress Theme and deactivated all plug-ins and then tried an upload and still had the same result...a white box.

  • David
    • Flash Drive

    We installed WordPress on this site with WP 5.5. It is a fairly new install. I followed the directions for a Multisite install (as I detailed in previous notes on this string). The htaccess file has been converted to a txt file and is attached below.

  • Nithin
    • Support Wizard

    Hi David,

    The .htaccess file also looks fine the rules in there shouldn't be causing any issue. I'm afraid, we'll have to give a closer look at the server-side to have a better idea regarding the issue.

    Since support access to your website was no longer enabled I couldn't also check the dashboard further. Is it possible to share the login credentials of both FTP and WP admin login so that we could have a better idea regarding this?

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login URL
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    hi David,

    Thanks for sending in the login credentials. Could I know how old is the Multisite? Was the Multisite created before WordPress version 3.5? The upload paths for the subsite is using the legacy upload path, under /wp-content/blogs.dir/ instead of /wp-content/uploads/sites/ folder.

    And hence causing the issue. In general, the latest install of WordPress should be automatically pointing to the correct paths out of the box.

    Also, when I create a new test subsite, it doesn't seem to get created automatically, and when I access the homepage of the new subsite it gets redirected to a signup page.

    Could I know how did you set up the 1st 2 subsites? You should be making sure to configure WildCard Subdomains so that the subsites gets created automatically.

    Please check this article on how to configure WildCard Subdomain:
    https://www.namecheap.com/support/knowledgebase/article.aspx/9191/29/how-to-create-a-wildcard-subdomain-in-cpanel

    It seems like the /blogs.dir path is hardcoded in the database side, to switch to a new path, could you please share your websites cPanel or PHPMyAdmin login, so that we could check further on correcting to a new path?

    You can send the credentials the same way as done before. Looking forward to your response. Have a nice day ahead.

    Kind Regards,
    Nithin

  • David
    • Flash Drive

    Nithin:

    Thanks for continuing to test on this. As I have noted in previous posts, I created the site ksvype.com and the subdomains all in June 2019 using the newest version of WordPress. I followed the directions for the creation of the subdomains the same way I did for okvype.com and its subdomains, all of which function fine. This is what is so frustrating to me.

    I checked PhpMyAdmin. In wp_options for the subdomains they were showing, as you said, the blog.dir. I did make the change in there to go to /wp-content/uploads

    As for creating the new subsite, I also ran into that issue. I am not sure why.

    Even after going into there and making the change, it still did not upload. Maybe there are other settings missing.

    I will send you the CPanel login

    Thanks
    David

  • Nithin
    • Support Wizard

    Hi David,

    As I have noted in previous posts, I created the site ksvype.com and the subdomains all in June 2019 using the newest version of WordPress. I followed the directions for the creation of the subdomains the same way I did for okvype.com and its subdomains, all of which function fine. This is what is so frustrating to me.

    It's odd if the WordPress install was a brand new. Maybe WordPress was installed automatically via any auto scripts? There isn't any way such legacy folders would get created in other instances.

    I As for creating the new subsite, I also ran into that issue. I am not sure why.

    As stated in the previous reply creating a Wildcard Subdomain should resolve issues with creating new subsites.

    Thanks for sharing the login credentials, I went ahead and checked the DB, and all the file instances but I'm afraid, the issue still exists, even after pointing to the correct Upload paths, and creating new /uploads/sites/ folders, and tweaking the wp-config.php, and .htaccess files the changes don't seem to get reflected.

    I have reverted the changes done except deleting the /sites folder, which I have renamed to sites-off for now. I'm afraid, this needs further troubleshooting, and I'm bringing this into our Second Level Support(SLS) teams attention to see what else should be configured, or being missed regarding this.

    Please do note that SLS works on complex issues, and has a slow response time. Will keep you posted once this is troubleshooted further asap.

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.