Implemmenting a validation pluguin in wordpress

I´m creating a system for one of my clients, the system needs a fancy complicated form to be filled, I want to validate some fields (numeric fields whit a minimum of 0.1 and a max value of 3, some fields are requiered, etc), and I need to make the site compatible whit IE8, I try to use some validation plugins from jquery but they did not work, whats the correct way to make work a jquery validation pluguin in the last version of wordpress? I was trying to implement this one http://jqueryvalidation.org/ ¿do I need to use anonther one?