Importing a snapshot from another site

I am importing a snapshot from another site, for the purposes of syncing the two.

The source site is beta.mysite.com (I'll call it "beta" from here on), and the destination is temp.mysite.com (I'll call it "temp":wink:.

Beta has a server problem, and Temp is a few-days-old backup of beta (from before the server problem started). Some post/page content edits were made on Beta after the backup was made, so now I need Temp to be synced with Beta.....and after that, we'll be taking down Beta and renaming Temp so it will become the Beta site.

(I will be doing a full serialized search/replace on Temp before going live with it, so all the internal links will be properly fixed up.)

I ran a Snapshot Pro backup on Beta, and uploaded the resulting zip file to the Temp server. Then I went to Temp, and used the "Import" functionality to import the zip file. It now shows up under Snapshots >> All Snapshots.

So far, so good. But.....

Now, according to this article:

Find your snapshot listed, then hover over the title and select the restore link. ...
Next, you should be redirected to the archive page for all the backups for the snapshot profile you chose.

So I click on the "restore" link, but this is what I see:

There is no restore link when I hover on resources.zip -- only a "delete" link. But I can click on the "Edit Item" button at the top of the page, and it opens up this screen:

I understand the first part, in red letters: Since this backup is from a different site, it doesn't "match" this one. So I select the corresponding subsite of my multisite network that I want to restore this backup to. That part is fine.

But as I scroll further down this page, I see that none of the boxes for "tables to include" are checked.

I don't recall exactly which boxes I checked originally when I created the backup, so what do I do here? What happens if I click the wrong ones, or leave something unchecked?

Basically the whole rest of the page is options I would see when creating a NEW backup, and I'm just not sure how this will affect the existing backup file (if at all). Maybe these settings are just for future backups that potentially will be created with this snapshot?

Just looking for some direction here, so I don't break anything. :slight_smile:

  • Adam Czajczyk

    Hello kalico,

    I hope you're well today and thank you for your question!

    You are right about that: these options are there to let you adjust backup settings for future use. By going to "Edit" screen for a snapshot you are not going to restore it but - as you already mentioned - change its settings for possible future backups.

    The first path that you followed with this is the correct one. I'm not sure however why there's no "restore" link there after you imported the archive. I'd like to give it a closer look so would you mind letting me access your site and check it? You could grant me a support access by following this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    It would also be great if you could additionally upload the original snapshot archive (zip file) to the Media Library of your site for me to download (in case I wouldn't be able to do it directly from Snapshot plugin) so I could test it on my test setup.

    Best regards,
    Adam

  • kalico

    Hi Adam Czajczyk Yes, support access is open (sorry, I should have mentioned it -- I opened it for another issue). I uploaded two files to the media library of the main site (beta.nrocnetwork.org) so you can test them: "main.zip" and "resources.zip".

    Not sure if it's relevant, but I have a false reading on used backup space, thought I don't have any sites with backups. It's addressed in this ticket.

    Thank you! :slight_smile:

  • Milan

    Hello kalico ,

    Hope you are well today and won't mind me chiming here. :slight_smile:

    I checked your site and imported snapshot on my local installation site. I can see "restore" link there so it could be specific to your "temp" site. Have you tried snapshot restoring on other dummy sites ? If not, would you please create one more dummy site and test it there ?

    Let me know how it goes there. :slight_smile:
    Best Regards,
    Milan

  • kalico

    Hi Milan I'm grateful to you for jumping in. I know it's a team effort over there, and it's much appreciated.

    I went to do as you suggested, and discovered that something changed (compared to my original screenshot of this page):

    resources.zip (that was my name for the file I imported) has been exploded to its snapshot ID, and Archives: Pending is now Archives: Complete.

    There's still no "restore" link on hover, but something must have happened via cron when I wasn't looking.

    The only thing missing now (compared to the similar screenshot in Jenni's article) is that mine does not say Destination: Complete.

    I would like to understand what each of these designations means, so I can understand the process and better know how to work with it.

    I will also set up a different site for further testing.

    Thanks for your help! I'll get back to you (all) when I have another site up for testing.

  • kalico

    Sorry to post again, but I just learned something that might help for the next round of testing:

    1) If I click on "Restore" from the All Snapshots page, there is no "delete" option on the archive.
    2) If I click on "View" under the "Archives" column of the All Snapshots page, then I *do* see the "delete" link.

    At least I can delete the imported backup now...but I still can't select to restore it.

  • Dimitris

    Hey there kalico,

    I trust you're good today and don't mind me jumping in!

    I just wanted to take another shot on this but I don't have access in temp.sample.com.
    Feel free to grant us support access to this or to the new install you're working on as I was also able to see the 'restore' link after importing your snapshot.
    Please do correct me if I'm looking at the wrong place here. :slight_smile:

    Cheers,
    Dimitris