Importing comments does not work

I’m having major issues importing comments with the Ultimate Facebook plugin. Automatic importing has never worked, and only after hours of tinkering and repeating steps have I been able to manually import any comments – and unfortunately it never works the same way twice, Ive been unable to replicate it.

Here’s what I know so far.

1) I have properly created my FB application, and when I click on the Ultimate Facebook Settings page, it shows the green check mark and says “Successfully connected to App”.

2) The initial attempt to “Grant Extended Permissions” was successful. However, while troubleshooting I attempted to un-authorize these permissions and then re-authorize. I’ve noticed that now the “Grant extended permissions” link either never shows up (shows the FB waiting line/bar graphic), or when it does show up and I click it, a window pops up with an FB warning that just states “An error occurred. Please try again later.”

3) After repeating all these steps, clearing browser cache, completely logging out of Facebook, and banging my head against the wall for a few hours, at some point the “Grant extended permissions” actually works properly. I am only ever able to import comments manually during the same session immediately after the “Grant extended permissions” has worked. It seems like something is being lost by Ultimate Facebook after this initial authorization.

4) Even when comments import, there are problems: comments are imported for any linked article whether or not the article is on my blog, and then those comments cannot be deleted (I opened a separate support request on this topic). Also, only about half of the comments ever get imported.

5) I’ve tried activating and deactivating Ultimate Facebook which doesn’t seem to help. I’ve tried creating a new Facebook app which also doesn’t seem to help.

6) The only other Facebook plugin in use is a plugin called Digg Digg. I’ve disabled this and completely removed which appears to have no effect whatsoever.

The wordpress install is:

Your assistance is greatly appreciated.