Importing File Larger Than 1 mg

I am moving some existing sites to a new multisite, using Wordpress import. The size limit is 1 mg, and 3 of my sites' xml files are larger than that (3, 4.5, and 5.4 mg). I know I read somewhere about splitting the files, but I can't find it now. How can I get these files transferred?

Thanks, Jill

  • Vaughan

    Hi @cbo,

    1mb is extremely low, It might be quicker & easier to see if you can increase the fileupload limit itself.

    This might help.

    http://www.wpbeginner.com/wp-tutorials/how-to-increase-the-maximum-file-upload-size-in-wordpress/

    If you get stuck though, let us know, but it might be worth asking your webhost too if you need to edit php.ini as it could be that they have set a limit, and they should be able to help you with increasing the limit on your account.

    Hope this helps.

  • aecnu

    Greetings Jill and Vaughan

    As Jill can confirm none of what was in the link/referred post was accurate to cure Jill's issue.

    Her host (guess who has the post_max_size and the upload_max_filesize both set at 2000MB as standard server configuration as shown in the first screen shot below.

    So though this may have been the answer for some folks on other hosts - since this host has it together the answer and cure for Jill - which was never mentioned in the referred link nor the above post - was in my opinion the simplest cure to the problem and required none of the procedures outlined in the referred link or post and the cure in this case and most cases --> being logged in as network admin go to --> settings --> network settings --> Max upload file size and change the value there. Screen shot 2

    This certainly did the job for Jill and I am certain will help many others having this same issue that do not need to go through all the hoops that link/article mentions ... this is indeed where to start for those wanting to increase the size of the file uploads and indeed in some cases once this item I mentioned has been checked and the issue still exists - as Vaughan accurately suggested/offered the php.ini is the next stop for finding a cure.

    Some hosts allow a php.ini file to be in effect that is in the root of the web accessible area - most commonly in the root of the /public_html/ folder - and if this is the case one would simply create a text file using notepad or the like that saves text verbatim (without styles or anything) with the following text:

    ; Maximum size of POST data that PHP will accept.
    post_max_size = 2000M
    
    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 2000M

    NOTE: The host must have allowed this - both that the php.ini file has an effect on the installation and the size for these two items as well.

    In a further effort to be helpful to those having this issue I have taken the liberty to attach a php.ini file to this post - attached as php.txt which will need to be renamed php.ini before it is applied/uploaded to the host.

    Obviously I have set the max sizes to 2000M, short for 2000 MB.

    Hopefully this post will help clarify things for those having this issue and starting with the basics in network admin before finding the need to dig into php.ini files or other configuration files.

    Have a GREAT day folks!

    Joe