Impossible to run Hummingbird GZIP compression

Hi,

I have a very bad speed page result: 21.

By running WP Smush pro and Hummingbird, I went from 21 to 22 score.

"The main problem is the GZIP compression that needs to be done, but cannot be run:
gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration"

I have desactivated all plugins, but the GZIP does still not compress.

I run the wordpress site on 1and1.

Thanks for letting me know how to improve page speed and be able to run Hummingbird GZIP compression.

Merry Christmas and kind regards,
Sophie

  • Dimitris

    Hey there Sophie,

    I trust you're doing good today!

    Are you under Apache or nginx server? This can be found in GZIP settings page.
    Here's for example a test installation of mine under an Apache server.

    In this case, what HB does, is to insert some rules in .htaccess file of your installation. Could you please confirm that these rules are already in place?
    If not, please backup .htaccess file locally, and insert these rules manually as shown in HummingBird -> GZIP compression (just keep in mind not to remove the default WP rules you have in there).

    If the error persists, could you please contact your hosting provider about this?
    As they may limit this in their server architecture, they should be able to enable the "mod_deflate" module for you that HB needs for its gzip functionality.
    Also please let them know that you need gzip compression for HTML, CSS and JS files.

    Warm regards,
    Dimitris

  • Praveen Thirumurugan

    Don't worry to enable GZip in every site in your hosting,
    Follow this steps:

    1) Login in to the cPanel of your Hosting.
    2) Go to Software -> Select PHP Version (Search is easy).
    3) Check the 'zip' box at the end.
    4) Now GZip is enabled for the whole hosting files.

    If that doesn't work,

    1) Go to Software -> Optimize Website.
    2) Select 'Compress All Content' and click 'Update Settings'
    3) GZip should be enabled.

    If this also fails,

    1) Try refreshing the website with 'Shift + Refresh'. This will delete all the cache.
    2) Use .htaccess method as described by the host.

    Thanks,
    Praveen Thirumurugan.