Improve loading times

The homepage loading speed is slow. How can I best optimized it ?

  • Nithin

    Hi Manjeet Singh,

    Hope you are doing good today. :slight_smile:

    Could notice Hummingbird cache isn't getting reflected for some odd reason, even after it's enabled. The header response of the site doesn't seem to point out the page is cached.

    Is this a live site? Is it okay, if we test further in your system, by temporarily disabling all the plugins in your system, except WPUM DEV Dashboard, and Hummingbird? Please do let us know.

    Also, please share your sites FTP, or cPanel login credentials too, so that we could troubleshoot this further.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -FTP or cPanel credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Manjeet Singh,

    Thanks for confirming about running conflict test, however could you please share the FTP login credentials asked in my 1st reply?

    Please go to the following link:
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    And send the FTP login credentials and the link to this thread for reference, so that I could give a look at the server side, before running a conflict test.

    While sending the login, to mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas

    Regards,
    Nithin

  • Nithin

    Hi Manjeet Singh,

    Hope you are doing good today. :slight_smile:

    If you give a closer look at the Performance test, under Hummingbird > Performance Test page, you'll notice following improvements that could be done to make the site load faster.

    Let's go through each factors:

    1) Optimize Images - There are couple images which is marked as "Compressing & Resizing" in the performance report, which means that the image is larger than the content width of the theme.

    I have manually resized those images as mentioned in the following article, and they are now optimized fully:
    https://premium.wpmudev.org/blog/compress-resize-images-wordpress/

    2) Render Blocking Resources
    This is something which'll require trial, and error method. There isn't any one specific steps that we could provide to improve this.

    Under Hummingbird > Asset Optimization page, you'll notice all the files listed in there which is loading in your website.

    You'l notice options such as "Compression", "Combine", "Move to footer" etc listed for each files. You'll have to enable these options in order to improve render blocking issue.

    The general rule of the thumb would be to move the files to the footer in order to reduce render blocking issue, for example:

    1) Go to the 1st file listed in the Asset Optimization page, enable "Compression" option for the 1st file,
    2) Load the frontend, and check whether the homepage design, or layout breaks
    3) If not, you can enable the "Combine" option, and then check the homepage, and see whether the layout breaks.
    4) If the layout breaks this time, you'll have to revert the "Combine" option Save the changes, and move on with the next step which is "Move to footer", and check whether it breaks the style, if yes, revert if needed. Then carry the step 1 again for the next file, until you get an optimised result.

    The only way to find out which exact file needs to be moved to footer etc is only via Trial, and error method. As this is something which is entirely depended upon your theme, and will vary from one theme to another.

    This is something you'll have to perform, and configure on your own, as configuring Render Blocking issue is something which is outside our support scope.

    3) Improve Server Response Time
    I checked your website, and I ran a pingdom test:
    https://tools.pingdom.com/#59df8957f5400000

    The sites current load speed 6.02 seconds, with the server taking 3 seconds to establish an connection.

    On checking further, I could notice that, for some odd reason the Hummingbird cache enabled doesn't seem to be working when I load for homepage, which is odd.

    I couldn't notice the hummingbird-cache: Served header being passed, which states that the cache is working. So, I tried to run a plugin conflict test as asked before to see whether the cache headers are working correctly when the plugins are disabled, except WPMU DEV Dashboard, and Hummingbird.

    Unfortunately, running the conflict test has brought the site throw a 500 error, which could happen if there is any specific plugin which was deactivated before deactivating the plugin specific add-on etc

    I tried to rectify this by logging into FTP login shared, but unfortunately it's only loading the wrong folder path, which makes us unable to access your server file to correct this 500 error.

    I checked with my colleagues, and even they are seeing the same issue with the FTP login. Could you please update the path in the FTP login, so that I could access the root folder of your website, and correct the 500 error, and continue with troubleshooting the issue with Hummingbird cache further.

    Please share the login the same way as you have done before previously.

    Regards,
    Nithin

  • Nithin

    Hi Manjeet Singh,

    The FTP login is working fine now. Thanks for updating it. I tested the issue further regarding cache, and I could notice Polylang plugin is causing a conflict with Hummingbird Cache, and which in turn doesn't seem to make the cache work.

    I tested in my local server too, and I could notice anomalies regarding this. I'm bringing this into the developers attention, to see what could be done to make sure Hummingbird Cache is working fine in your website in such use case.

    Other improvements, what you could do in your server side, is to check with your hosting provider, whether you have OPcache extension enabled in PHP side, if not, enabling OPCache should help with improving your servers response time.

    Also, I could notice the current PHP version running in your system is version 5.6, would recommend you to ask your hosting provider to upgrade PHP to at least version 7.0 or greater. PHP 7+ should improve your sites overall performance, as it's really faster when compared to v 5.6.

    Will keep you posted once we get further feedback regarding this from the developer asap. Have a great day ahead. :slight_smile:

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.