In addition to another unresolved issue I have posted here

In addition to another unresolved issue I have posted here (https://premium.wpmudev.org/forums/topic/i-having-trouble-setting-the-first-time-block-of-the-day-v#post-529909 ) I have the following problem:
1. Break times are not reflected in the calendar
2. Start date; Entered as [app_monthly_schedule ... date="2013-11-14"]
but appointments still displayed as available prior to that date.
Really like to get these and the other issue resolved for my client.
Cheers
Colinz

  • Patrick
    • Support Monkey

    Hi @colinz

    #1. Have you double-checked that the break-times have been set for the correct service provider(s)?

    #2. Regardless of the day you enter in the date parameter on the app_monthly_schedule shortcode, it will default to the beginning of the month.

    The same principle applies to the weekly app_schedule shortcode. The output will default to the beginning of the week corresponding to whatever date is specified.

    Also, your shortcode should not contain an ellipsis ( ... ). That is in the shortcode docs simply to illustrate that there may be other parameters in there too. :slight_smile:

  • Patrick
    • Support Monkey

    @colinz

    #1. I see on your site that there is only one service provider. Please try setting the break times for "No specific provider" also. There are a few functions in the plugin that default to that when there is either 1 or 0 providers defined... this may be one of them :slight_smile:

    #2.

    So I need to add an exception that runs up to the launch date when the shop opens?

    That would work if all you need is to block off specific dates until your site launches.

    As for the shortcode, the thing you do not want in there is the ellipsis. That's those three dots like this
    ...

    But you need the square brackets for any shortcode. Without them, the shortcode will not work. So your shortcode would look like this:
    [app_monthly_schedule date="2013-11-14"]

    But once again, any day date entered in the shortcode will default to the 1st of the month for the monthly calendar shortcode, or the 1st of the week for the weekly calendar shortcode.

  • colinz
    • WPMU DEV Initiate

    Thanks for following this up, unfortunately not 100% successful

    try setting the break times for "No specific provider" also.

    Tried that and still will not display the lunch break... I cleared cache to see if that would help.

    Thanks for the shortcode clarification.

    If you could come back to me on the lunch break not displaying, I would be grateful.

    Colinz

  • Patrick
    • Support Monkey

    @colinz

    Hope you had a great weekend!

    I just took another look at your site and see that you have set things up for only the one service provider, and that the break times do appear to be blocked off correctly.

    What was the issue preventing the break times from displaying?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.