In Appointments+ I want to limit the availability of a Service

I have a service set that is kind of orthogonal to the usual set. In this scenario, the services are published as available only on certain days and a specific service provider provides the service for that time, but may provide a different service at another time. For instance, a service provider is available to provide a service every Monday from 1:00 to 4:00, but will be available for a different service every Wednesday from Noon to 5:00. Is there a way to limit the availability of a specific service?

  • Ash

    Hi Dan

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    What you can do I think, Create two services e.g. A for Monday and B for Wednesday. And create two services providers for same person to attach with two services e.g. A-Service and B-Service. Then from working hours tab, for "List for" select "A-Service" and "B-Service" and set working hours for them.

    Please let me know if it works for you and feel free to ask if you have any more question.

    Cheers
    Ash

  • dmuchnok

    Hi Ash,

    That had definitely occurred to me and that is the way I configured the first service. The only drawback is that I couldn't post a calendar on the service provider's page to display all of the services that he/she can be scheduled for. That is a minor point, however, so I will definitely do that. I can even point the multiple service providers to the same information page, so the user doesn't have to know that it's two "different" providers.

    Thanks!

  • pxwm

    Hi @Ashok - I hope you don't mind me chiming in

    Hi @Dan

    To expand on the suggestion by @Ashok you could try the following:-

    Create 2 x Wordpress users, one for the 'real Service Provider' and one for the 'dummy 'Service Provider'.
    Make sure the 'real' Service Provider has the email assigned to them where you want the appointment emails to be sent to.
    Don't worry about the email for the 'dummy' Service Provider as their appointments will be sent to the 'real' Service provider.

    Then Select A+ 'Service Providers' tab and:-
    Create your 'real' Service Provider and assign the 1st Service to them and also setup the relevant working days/hours to support the 1st Service
    Do NOT tick the 'dummy' checkbox

    Then create a 'dummy' Service provider and assign the other Service to them and setup the working days/hours to support the 2nd Service
    Make sure you click the 'dummy' checkbox

    Then Save

    Then select the A+ 'General' tab and scroll down to the 'Assign dummy service providers to' field and select the 'real' Service Provider from the dropdown

    The Save

    Then try making an appointment to see if this works.

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.