In CustomPress, what might cause the Featured Image block not to appear on the Edit Post screen for

Hello. I’m just setting up CustomPress on a site that has pre-existing custom type posts that were created manually in functions.php. I’m delighted to say that the plugin is recognizing the old posts appropriately. I wasn’t sure it would work that well.

But my question: These posts have Featured Images, and I have set up the type properly in CustomPress, having checked the “thumbnail” box under “Supports”. The Featured Image block is not appearing in the Edit screen for these posts, though. I have also checked under “Screen Options”, and it is not available there as a checkbox.

On the other hand, on the template side, the right images are showing up.

What might be the reason for this?

Many thanks.

  • Mason
    • DEV MAN’s Sidekick

    Hiay @cantusfirmus,

    I haven’t had a chance to explore this specifically, but my hunch is that even though CustomPress can “see” the other post types, it’s not registering the additional fields properly.

    Would it be acceptable to add the thumbnail support in your theme’s functions.php file? Or are you saying that before adding CustomPress the post_type showed the feature image area (since you can see them on the template side)?

    Let me know. A link might also be helpful to see what’s going on. Thanks!

  • CantusFirmus
    • Flash Drive

    Yes, this is a weird one. I just tried switching themes, and indeed, in Twenty Eleven all is well. So, there’s something this theme (My Site My Way, Fusion) doesn’t like about this.

    The theme does have thumbnail support for native post types.

    I’d welcome any thoughts, if this info helps you zero in on it. I can’t provide a link, because it’s only visible in the Admin. I can create a login for you privately, if you’d like.

    Many thanks.

  • Mason
    • DEV MAN’s Sidekick

    Hiya @cantusfirmus,

    That’s really odd. If you can send me a message with wp-admin credentials and ftp access so I can see the theme code, I’ll take a look.

    Is it a premium theme from somewhere? Wondering if the developer might have an idea.

    Just put my name in the subject, a link to this thread for reference, and the credentials through our contact form here:

    https://premium.wpmudev.org/contact/

    No guarantees, but if I can find something quickly I’ll let ya know. Thanks!

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    In CustomPress it mentions that the current theme must also support post-thumbnails next to the Featured Image setting. This was missing from the theme.

    I added the following to the functions.php file and now all seems to be in order:

    add_theme_support( 'post-thumbnails' );

    Let me know if this sorts it for ya or if you have any further questions.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.