In Discussions, the subnavigation disappears

Hi, when a user clicks the discussions link, the list of discussions is shown. However, once they click into a discussion, the subnav inexplicably disappears, leaving the student hanging.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @rogera,

    Hope you are doing good today :slight_smile:

    It appears to be issue with your theme. Please switch to default theme or use CouserPress theme and then check again.

    Also, run a plugin conflict test if above does not help as described in getting support manual.
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    (I avoided to do it myself on your live site without your permission and without having FTP access)

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:
    Cheers, Sajid

  • Roger Allsopp
    • Site Builder, Child of Zeus

    Sajid, this is really not a solution at all. One of the key reasons I selected Coursepress is because it is a plugin, enabling me to seamlessly switch from main website to online courses whilst retaining the same branding and design. I am also using one of the most popular Wordpress themes. Had I known, I would have installed Moodle instead and not had all these issues.

  • Nastia
    • Support Rock Star

    Hello Roger, I hope you are doing well today!

    My colleague, sajid, asked to switch to the default WordPress theme only for testing purposes. It will help us to determine if the theme causing this issue or another plugin. Once we know what causes this behavior we can provide you with a fix.

    Would you please run a quick check for a conflict with a plugin/theme?

    Deactivate all other plugins and test again. If the issue is gone, please activate one plugin at the time to find out which one is causing this conflict.

    Please follow the flowchart from our manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    In case you don't wish to test on your live site, please create a sandbox site (a copy of the existed one) and test it there. You can create a copy of your site with Snapshot plugin.

    I tried to login to your site using support access to troubleshoot, but I see 500 error. After, I enabled WordPress debug, there is a fatal error:
    PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 30720 bytes) in /var/www/html/yourdomainname.com.au/wp-admin/includes/class-wp-screen.php on line 1159

    To solve this issue, please define memory limit in wp-config.php file
    define('WP_MEMORY_LIMIT', '256M');

    We can also make a quick test on your site, but only with your permission.

    Let us know how it went!

    Kind regards,
    Nastia

  • Roger Allsopp
    • Site Builder, Child of Zeus

    Hi, I have spent all day on the site and identified 2 plugin conflicts. Yoast SEO and parts of Jetpack. Yoast has been removed, and the conflicting parts of Jetpack have been deactivated.
    This now enables the navigation to show on the Discussions pages, but for some reason, the navigation is larger, in a different position, and the page has the title 'NEWS' and a messy breadcrumb top-right. These issues still require fixing.

  • Roger Allsopp
    • Site Builder, Child of Zeus

    Update: I have managed to restore some CSS which has hidden the NEWS heading and the breadcrumb. However, I am still not sure why the subnavigation appears in a different size and position on this page compared to all the others. Can this be fixed?

  • Sajid
    • DEV MAN’s Sidekick

    Hi @rogera,

    Hope you are doing good today :slight_smile:

    I am unable to see the discussions page (in fact all pages other than home) on your website because of internal server error.

    Did you recently installed/updated any plugin or theme ? Or may be you have added in code snippets ?

    Please advice or let me know when your website is back so I can take a look at discussions quick links and figure out why exactly they are appearing different then the rest of the site.

    Look forward towards your response :slight_smile:
    Cheers, Sajid

  • Panos
    • SLS

    Hello @rogera,
    Hope you are having a great day!

    Concerning the font-size of the sub-nav in this page you can change it by adding the following CSS:

    #post-4780 .submenu-main-container #submenu-main .submenu-item a{
    font-size :15px;
    }

    The theme uses a different font size for text inside ".post-body" (18px) and "body" (15px). It wraps your submenu in a post-body that's why the font-size is different in that page.

    I am not sure I follow you about the position of it. Could you please provide further information on this matter?

    Thanks,
    Panos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.