IN-POST ADS not displaying in middle of page

In reference to this question:

https://premium.wpmudev.org/forums/topic/cannot-get-in-post-ads-to-load-properly-when-auto-inserted#post-830410

Access has been enabled, please help me figure out how to make the ads load in the middle pf the page as per the current settings. I have tried all kinds of methods and no matter what, some script always seems to break this down.

  • Michael Bissett

    Hey @Gabe! :slight_smile:

    As we're now working with a different site, we'll continue the discussion over here, but let's try to keep issues on a single thread in the future, okay? :slight_smile:

    As per your original question:

    I have been having this problem for some time on and off, but recently it has gotten very annoying.

    I use JS minifiers on my site for obvious reasons, but no matter what I do, exclusing wdca.js or even turning off the minifiers completely still always results in ads ending up at the bottom of the page when set to auto-insert in the middle.

    I don't want, not can, insert the shortcode manually in every single article, is there any way to reliably get this script to work as it should?

    Were you able to have a go at the basic troubleshooting flowchart that I referenced in my last post, the one in our Getting Support guide:

    https://premium.wpmudev.org/manuals/getting-support/

    Could you give me an example of a post where the post isn't showing up properly? The ones I tested so far don't seem to have any popup ads, and it'd help if I could have a bit more info here. :slight_smile:

    Kind Regards,
    Michael

  • Gabe

    The flowchart is not very helpful considering that I have a huge amount of necessary plugins to check against (even doing so I have found no specific one that breaks the post ads) and I have had things working with this configuration until recently. Here is an example of a page loading the add at the end, despite setting being ti insert in the middle. This happens in every page where the add is not manually added by shortcode. http://s9639.p140.sites.pressdns.com/economic-collapse-2/will-greece-default-on-its-debt-or-will-germany-negotiate/

  • Michael Bissett

    Hey @Gabe, my apologies for the delay here!

    In the process of going through the flowchart, did you also make sure to try switching to a default theme? (e.g. Twenty Fourteen) Didn't see that mentioned, and just wanted to verify that. :slight_smile:

    Also, when you said:

    I have had things working with this configuration until recently.

    What changed on your site around the time it stopped working? Did you add the JS minifiers around that time?

    Given the situation here, it'd be helpful if I could have a deeper look at things. Could you please send in the following via our contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    On the contact form (linked to below), please select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks! :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.