In-Post Ads show up in image captions

The in-post ads display in the image caption area, which I think is wrong.

Here's a screenshot of it happening: http://cl.ly/image/453A3P2S0d0q

Here's the post of the screenshot: http://crescentridgehomeowners.com/2012/04/03/update-86th-street-north-widening-project/

  • aecnu

    Greetings Clifford,

    Thank you for bringing this significant issue to our attention.

    In addition, that you for the screen shot and the URL as well.

    I agree that the ad should not be showing up in the caption as you have described happening.

    Therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Vladislav

    Hi,

    This happened because of the selector format - the caption is formatted as P, which falls under the selector definition and got counted as a possible insertion point for the plugin. The solution might be as simple as discarding such paragraphs from the selector. To do this, enter something like this as your "Elements selector" option, under plugin settings:

    p:not(.wp-caption-text),ul,ol

  • aecnu

    Greetings Clifford,

    It appears that the lead developer has indeed made his way in here with his solution.

    It appears this particular topic is now resolved/closed, if you need any further assistance please let us know.

    If it wasn't resolved, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.