Include Service Providers in Default Calendar - for Appointments+

I have successfully hooked up a Google calendar and tested ok.
I want all Service Providers as well as 'no preference' choices to add to the same calendar. At the moment only 'no preferences' get added to the calendar.

If i choose a Service Provider nothing is added to the calendar.

Please assist

  • Jack Kitterhing

    Hi there @neil,

    Hope you're well today and thanks for your question! :slight_smile:

    Currently with multiple providers added, the Google Calendar integration only works for the first service provider, this is a limitation of the Google Calendar API and we are looking into ways into working around this issue.

    One workaround currently, would be to have the service providers use their own calendars and then share that work calendar, so you can see one calendar with a overlay of everyone's working hours, if that makes sense? :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • neil

    Hey there Jack - maybe I am setting it up wrong.

    All the Service Providers in my scenario work for the same company so they only use the one Google Calendar which makes it easier for company to manage the bookings.

    http://dev-score.autopilotyourbusiness.com/make-an-appointment/

    So if I added the name of the Service Provider to the service and created multiple - that would kind of work, right?

  • pxwm

    Hi @Jack Kitterhing - I hope you don't mind me adding my feedback

    Hi @neil,

    You can achieve this but as @Jack Kitterhing has indicated you will need each Service Provider to have their own Google calendar and then you can share this with the current Google calendar so all the Bookings are not only visible on each Service Provider Google calendar but also on the current Google calendar.

    To achieve this in A+ you will need to:-

    Login as Wordpress Admin
    Select A+ Settings
    Select the 'Google Calendar' tab
    Set the 'Allow Service Providers for Google Calendar API Integration' field to 'Yes'
    Set the 'Appointments will be sent to Google Calendar for' field to 'All'
    From experience it is better to remove the following fields but save locally:-

    'Key file name', 'Service account email address', 'Calendar to be used'

    If you then Select 'Users' from the main left hand Wordpress menu
    Then Select a Service Provider user profile and scrolldown and you will notice that you now have similar fields to the main 'Google Calendar' tab.

    You now need to create a personal Google Calendar for each Service Provider through a Google account.
    Once created you need to generate an API key for each Google Calendar the same as you did for the 'Google Calendar' tab
    Then populate the relevant fields in the relevant Wordpress User profile and Save for each Service Provider.
    You then need to upload the private-key as per the main 'Google Calendar' tab for each Service Provider.
    Once complete you then need to share each of the personal Google Calendars with the current main Google Calendar.

    You can then go back to the Wordpress User profile for each Service Provider and there will be a 'test connection' link the same as in the main 'Google Calendar' tab.
    This test appointment should be sent to the relevant Google Calendar and also should be displayed on the shared calendar.
    You can set up colour keys so you can easily identify Bookings for each Service Provider.
    You can even use Google filter so you can just show Bookings for each Service Provider from the shared calendar therefore you don't have to use the individual Google Calendars.

    I hope this helps
    Regards
    SteveB

  • neil

    Hi - this is great thanks.

    So I could in theory just provide the same calendar details to each service provider as the default one set in the main calendar area?

    When I go to add the calendar to the users profile section the calendar area is greyed out eventhough in the main calendar tab i have

    Allow Service Providers for Google Calendar API Integration set to ' Yes' and
    Appointments will be sent to Google Calendar for - "All"

    Then when I go to the user section and toggle integration to 'A+Sync' the fields below for the calendar values are greyed out. When I update the profile the integration settings go back to "Integration Disabled"

  • pxwm

    Hi @neil,

    To confirm you have to use unique credentials for each Service Provider in their Wordpress user profile.
    ie. They have to have their own Google calendar and google api key, they cannot be shared.

    As for the fields being greyed out.

    Apologies I forgot to mention you have to be logged in as the Service Provider/Wordpress user to make changes in their user profile page.

    Also I would suggest if you are going to set up a Google calendar for each user then set the 'Integration Mode' field in the main A+ 'Google Calendar' tab to 'Integration disabled'

    I hope this helps
    Regards
    SteveB

  • pxwm

    Hi @neil

    I don't think there will be an upgrade to support this because effectively this functionality is already available.

    To confirm if you create a Google calendar for each Service Provider and then share them in a secondary Google calendar then you effectively have a single calendar.

    It then allows all the appointments for each Service Provider to be viewed in the shared secondary calendar and using Google filters and colour codes you can filter against each Service Provider.

    I hope I have explained in a way that will enable you to decide if this is what you require. If not please let me know.

    We have successfully used this method of sharing for one of our clients using A+.

    Regards
    SteveB

  • pxwm

    Hi @neil

    Unfortunately I can't answer your question in full because when we configured for our client we shared the individual calendars with a main calendar and we disabled the option for users to select 'no preference' so they had to choose a Service Provider.

    The main issue you have with users being able to book an appointment without selecting a Service Provider is that the appointment cannot be confirmed until Admin have assigned a Service Provider to the Booking.

    I don't see why it shouldn't work but I would suggest you would also have to retain the A+ 'Google Calendar' tab settings as well as the A+ 'Google Calendar' settings for each Service Provider.

    I hope this helps
    Regards
    SteveB

  • neil

    Hi Steve,

    Thank for the reply.

    For my solution - it still would be easier just for 1 calendar as all the service providers work at the same company and use the one calendar.

    For me to set it up as the plugin works means I have have to create a number of calendars and share them with a default calendar when I don't really need to, I understand what you are saying and appreciate the feedback.

    Do you work for WPMU? where could i get a quote to alter the code to suit my needs?

    Regards
    Neil

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.