Incompatibility between 'Membership 2'and 'rtMedia' plugins

Hi WPMUDEV team,

Nice plugins ! However I detected a strong defect in Membership 2.
Once you've created a new Membership, the file upload system is KO with the rtMedia plugin (used in a Buddypress context, please refer to the attachment).
Both plugins are just essential (I bought them) and as you've featured rtMedia on your WPMUDEV website, I did not imagine a incompatibility was possible.
Please propose me a fix ASAP, it is strongly needed. Thanks in advance for your help.

Regards,
Laurent

  • Adam Czajczyk
    • Support Gorilla

    Hey Laurent,

    I hope you're well today and thank you for your question!

    The issue in question seems to complex to be resolved on a basis of a screenshot only. That said, I'd like to take a closer look at your setup. Could you please grant me a support access to your dashboard using our WPMU DEV plugin?

    To do so, please follow this guide:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hey Laurent!

    Thanks for granting an access. I've visited your site and checked its settings. Nothing seems to be broken there at the first glance but there's a lot of plugins that make use of JS and I suspect that the JS is a culprit here.

    Have you tried to
    - disable all the plugins and then enable them one-by-one to make sure that the Membership 2 is causing this?
    - revert to a default WP theme (Twenty Fifteen preferably)?

    Please advise. If not, am I free to do this and some other checks? If so, then please backup your entire site and let me know!

    Cheers,
    Adam

  • Laurent
    • WPMU DEV Initiate

    Adam,

    I confirm that Membership 2 causes the problem. For test I have deactivated each plugin one by one and seen that it comes from Membership 2.
    More precisely, it is when a Membership is created in Membership 2 that the problem occurs.
    When I install Membership 2 for the first time without having created a Membership with the plugin, my [Upload zone] is OK. Then, when I create a new Membership, it is KO.
    I let you do the needed checks (I extend the Grant access).
    I'm sure I will not be the only one with this problem :wink:

    Thanks,
    Laurent

  • Predrag Dubajic
    • Support

    Hi @ Laurent,

    I have just tested two of my installations with Membership2 and rtMedia plugin and I was unable to replicate the issue.

    I have copied exact same settings as on your site and followed your instructions and it was still working for me so I'm not sure what could be the issue on your end.

    Can we do some further testing by disabling other plugins and switching the theme?

    Best regards,
    Predrag

  • Laurent
    • WPMU DEV Initiate

    Hi Predrag,
    Hum, I just :
    Changed my theme Socialize Lite to Twenty Fourteen. Then I delete Membership plugin, the problem disappears.
    And reinstalled it : the probleme is back.
    Same thing with Twenty Fifteen.
    Really annoying... When you say that you're unable to replicate the case, did you observed precisely the opening/closing of the file uploading box (from the rtMedia plugin) ?
    Thank you.

  • Laurent
    • WPMU DEV Initiate

    Predrag,
    I am confused ; I just activated / deactivated each plugins one by one and the cause was the plugin : 'Edit Author Slug'. Sorry, my checks weren't 100% good.
    So the problem is resolved. Thanks for having tried to help me. I hope this case may be useful for someone else !
    Cheers,
    Laurent

  • Laurent
    • WPMU DEV Initiate

    More precision : The defect occurs when I try to put as 'Author slug' the same name than the one used as a prefix/permalink for members in buddypress.
    I recreate the case with another plugin changing also the author slug.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.