Incorrect Admin URL after pro site checkout

Hello,

After checkout with paypal sandbox I'm getting the wrong admin url shown to my users.

This was listed as a fixed bug for prosites v 3.5.4 "Fixed: Show correct admin url for Paypal checkouts"
As you can see in the screenshot: the new site url is correctly shown at the top of the page, but the "Login Details" admin link is incorrect.

  • Adam Czajczyk

    Hello Dan,

    I hope you're well today and thank you for your question!

    I have visited your site and signed up for a test site using PayPal payment. You should now be able to see the "wpmutest" site on your site's list (you may remove it along with my account) and the admin URL that I got was the one that I should get. Take a look here please:

    Is there any specific step that I should take to replicate that on your site (like e.g. be logged in with specific user-role etc)?

    Please advise!

    Best regards,
    Adam

  • Dan Berdal

    It looks like I am no longer able to replicate the problem either.

    I was also experiencing an issue where the site would be created, payment would be taken, but the prosite level would not be applied. That issue was resolved by changing my default template in New Blog Templates.

    There is a chance that by solving that problem I also solved this one. I am not positive, but I think the issue with the blog template (and perhaps this issue too) was related to a plugin that has since been deleted.

    I'm testing out so many different plugins, and it's easy to test their functions, but it's a challenge when they start interacting on unrelated functions in other plugins.

    So, the problem is resolved, but I don't know why :upside_down:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.