Incorrect grammer in permissions message

When I go on a page that I don't have the correct permissions for, I get this error message:

"You does not have the correct permissions to access this feature!"

I need to change "does" to "do" but I'm not sure where to do that. Could you let me know please? The page is here:
http://txhubcouncil.org/hubmatch_post/

UPDATE: I went into "Membership" under "Options" under "Protected content message" and the message is:
I'm sorry, but you do not have access to this content. Please Join Now for access.

So I'm not sure where the "You does not" message is coming from. The contact is enclosed in a shortcode.