Increase PHP Memory On Both Servers for Migration

I need the server memory increased so I can use the Snapshot Pro to migrate a site. I was told you all can do this for me. Thank you!!!

This is the new site that needs migration. http://bankstonb.digitalpublicitygroup.com/
This is where I will migrate it to bankstonbrokers.com

I dont have specific details for just FTP access. But I do have GoDaddy creds. Will someone contact me so I can send the details and get this completed?

  • Nithin

    Hi Jeff,

    Hope you are doing good today. :slight_smile:

    Could you please check and confirm whether you are getting either of this error as described here: https://premium.wpmudev.org/blog/increase-memory-limit/

    If that's the case increasing the memory_limit at php.ini file should do the trick, if you are unsure about making those changes, we are happy to help. :slight_smile:

    You can send credentials by using our secure contact form http://premium.wpmudev.org/contact/

    Select “I have a different question” for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -Credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day.

    Kind Regards,
    Nithin

  • Nithin

    Hi Jeff,

    Hope you are doing good today. :slight_smile:

    I have made the changes by increasing the PHP memory limit, and I believe it should work smoothly. The changes are made by adding the .user.ini file in your root folder of your WordPress installation.

    upload_max_filesize = 64M
    post_max_size = 96M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 180

    You can check the values in WPMUDEV > Support > System Info.

    Regarding your other website, since it's a shared hosting, and you are planning to reinstall WordPress, making changes to .user.ini in your WordPress directory will overwrite once you reinstall. What I can recommend you is to follow the directions as stated above, once you reinstall. If you are finding it difficult to make those changes, please do let me know once you finish reinstalling, so that I can help get you setup the new file.

    Please let us know if you need any further help. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Jeff,

    Hope you are doing good today. :slight_smile:

    I checked your installation, and was able to replicate the error in your system when trying to backup the media folders. Error generated is quite an odd one, and I have pinged the developer regarding this behavior.

    Please do note that developers work round the clock, and have a slow response time, either myself or the developer will keep you updated.

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Jose

    Hello there jeff,

    I was taking a look into your site and created a test snapshot.

    The problem seems to be caused by your media folder. Specifically, with some media file located under ../media/2016/05. Maybe a permissions issue, a file that is too large, or a corrupted file.
    I'd suggest to check via FTP if you can spot some large file and exclude it from the snapshot.
    Alternatively, you can exclude the whole medi files and move it manually via FTP once the site is migrated.

    Please let us know if this works for you.

    Cheers,
    José

  • sergio

    I do have a question though,

    I'm setting up Snapshot for the first time. I've used other backup plugins up til now, and I already had this doubt that I tried to solve surfing blogs, posts etc... But I cannot seem to get a clear answer on this:

    If you need to increase memory, say to 512, you do it via tweaking the .ini file, ok, but if your server's limit is set to 256, wouldn't it be useless?

    I mean if the server's PHP memory tops at 256, wouldn't that amount "rule" over whatever limit you input in the .ini file?

    I've read and have been told all kinds of things, and still cannot have a clue...

    I hope I make myself understandable :smiley:

    Cheers!

    • Jose

      Hey Sergio,

      You are right. You can't increase the memory limit above server's limit.

      Also, some hostings won't honour the php.ini or ini_set() directives. The best way to check whether or not your tweak is taking place is by printing php_info() at the beggining of your script, or right bellow the directive in the case of ini_set().

      Something like this:

      ini_set('memory_limit', '512M');
      phpinfo();

      That way you will get all the information including environment variables and you can check what's the value that is picking up for memory_limit.

      Cheers,
      José

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.