Individual Page address

when I am creating a new page within a site (http://mynetwork.com/mysite/wp-admin.php), the URL of the page is http://mynetwork.com/mysite/wp-admin.php.

Is there any way I can create a page from within the network domain that will have the URL of the sub-site admin defined in the Domain Mapping plugin.

I think there is something that was overlooked when this plugin was designed. the site should behave completely like a subsite wether accessed from the network (http://network.com/mysite) or from the site's URL (http://mysite.com)

  • Timothy Bowers

    Hey taropaa. Hope you are well!

    Yup full instructions are here:

    https://premium.wpmudev.org/project/domain-mapping/installation/

    Domain Entered By The User – If a user has mapped a domain, then with this option enable you and your user is able to access the admin area with both yourdomain.com/wp-admin/ and clientdomain.com/wp-admin/

    Mapped Domain – With this one chosen you and your users will access their admin area whichever domain is mapped. Don't worry if you use clientsite.yourdomain.com/wp-admin/ then it will simply forward to clientdomain.com/wp-admin/

    Original Domain – As it says, the original domain. So that would be clientsite.yourdomain.com/wp-admin/

    So if you want the sub site to use their own domain then you would select the "Mapped Domain" option.

    Of if you want both options to work to ensure the admin still works whilst a domain DNS is resolving then you can select the "Domain Entered By The User" option, that way both work.

    Hope this helps.

    Take care.

  • aecnu

    Greetings taropaa,

    Thank you for being a WPMU Dev member!

    In the network dashboard go to Settings --> Domain Mapping --> Administration mapping

    The settings below allow you to control how the domain mapping plugin operates with the administration area.

    The domain used for the administration area should be as shown in the graphic below.

    Cheers, Joe :slight_smile:

    If this thread is not resolved because the suggested action did not work or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

  • taropaa

    I do have the define( 'SUBDOMAIN_INSTALL', false ); set. I will try to enable subdomains and let you know how it goes. It appears that once pages are saved and it shows that the URL is http://network.com/mysite/page when accessing the wp-admin from the custom domain the url displayed is mysite.com/page so I think I will keep the original domain for now.
    I was wondering if there is a way to just fix this cosmetically so that users don't get scared that they will be directing traffic to the network domain instead of their own.
    I will continune to investigate the issue with the text editor so see what it takes to get it working on the custom domain admin.

    If you have any ideas, please let me know

  • Timothy Bowers

    Domain Mapping should let the site function as if it were standalone install. i.e. if you select the mapped domain, then the admin should function like it was a normal site.

    I have a reasonable sized production install which works just fine with domain mapping and a sandbox install which also functions right.

    On your install what happens with the editor? Are buttons just not clickable? Something else?

    Whats a false positive from Cloudflare?

    Because its not I would suspect some kind of conflict with a plugin or theme. what happens with all other plugins disabled and using the default Twenty Eleven theme?

    If you can't test on your live site, then please use a sandbox/test install.

    Let me know.

  • taropaa

    Cloudflare is a CDN which also acts as a security system for sites. It is invaluable for sites aiming to get higher traffic rates without punishing the server too much. What they do is look for suspicious behaviour on sites and if such behaviour is detected, that user gets kicked off the site and presented with a captcha page.
    What used to happen (with wordpress multisite subdomain mapping off) was that I was accessing the site using the custom domain http://mysite.com/wp-admin, but (i'm guessing) the site was expecting the same domain as an origin for all scripts since they were being served from networkdomain.com, and here I was accessing the site from mysite.com and basically receiving scripts from another domain; also when executing the update or publish command, wordpress(and cloudflare) were expecting the request to be made from networkdomain.com, since the official site was on the same domain as the network (networkdomain.com/mysite) and just mapped to mysite.com. It's a bit twisted, but this is what I think was happening (roughly :smiley:)

    What I think this is saying is that the mapping is causing some sort of glitches for subfolder installs.
    After switching the site over to subdomain installation, the sites seem to be working ok.

  • taropaa

    Yup, sites are ok now. I had some issues, as you would expect when performing such a switch, but nothing that could not be fixed.

    The plugin seems to be working fine for subdomain installs only. If you have a subfolder version of the WP Multisite, then you run into trouble.

    Its up to you guys to decide wether you want to support subdirectories or not, but for now I would put a note in the plugin page so you don't get any angry users :smiley:.

    Thanks for the support!