Infinite SEO Category Not Working

I have a theme template called category.php

This template is being used on my category pages such as:
http://domain.com/category/food/
http://domain.com/category/drinks/
Etc.

In Infinite SEO, I am using the following macros:

TITLE: %%category%% | %%sitename%%
DESCRIPTION: %%category_description%% | %%sitedesc%%

However, on my website, both %%category%% and %%category_description%% are blank. Both %%sitename%% and %%sitedesc%% work correctly.

What must I do to ensure %%category%% and %%category_description%% works correctly?

UPDATE: Actually %%title%% also doesn't work in the "Category Title" and "Category Meta Description" fields!

  • aecnu
    • WP Unicorn

    Greetings targetdir,

    Thanks for bringing this up, it certainly sounds like a useful customization to the plugin.

    I am now going to discuss it with the lead developer - to get a fix sorted for you asap.

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

  • Vladislav
    • Dead Eye Dev

    Hi,

    I have tried to reproduce this behavior so I can figure out what's exactly happening, but unfortunately haven't been able to this far. Can you please tell me how exactly are you applying your template? Is it perhaps a page that has page template applied?

  • Timothy Bowers
    • Chief Pigeon

    Hey targetdir, hope you are well.

    We have not heard from you in a while so thought I would check in to see how things are going here.

    Is it all sorted now?

    I've marked the thread as resolved for now as we haven't heard from you, however if there is still a problem then please open it back up so we can further assist. :slight_smile:

    Can you please tell me how exactly are you applying your template? Is it perhaps a page that has page template applied?

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.