Infinite SEO - Sitemap generator problems with multisite

Hi there,
I have already contacted you about this issue over a week ago and also emailed with a guy named Dave at WPMUDev.

I am using InfiniteSEO in a multisite environment where the plugin is directed to each of the child sites where you can customize it based on the child site rather than on the network admin level. Everything but the sitemaps seems to be working fine. The sitemaps, however, do not work properly. Google Webmaster Tools only allows for the actual website name.com/sitemap.xml for example. In InfiniteSEO, it displays my sitemap URL as websitename.multisiteinstall.hosting.com/sitemap.xml and there is no way to edit the sitemap url to only be websitename.com/sitemap.xml.

As previously stated, I have already contacted WPMUDev over a week ago with daily follow-ups being emailed to Dave. I also placed a ticket here which they confirm they received. I have also provided all of my login information to WPMUDev. Please advise on how I can handle this. I need to resolve this issue on my sites ASAP.

Thanks!

  • David

    Hi Michael,

    Multisite was set up for us. I did not set it up personally. I add sites and domain map them according to the instructions provided which was not a problem until this sitemap issue. You can visit the actual domain name (domain.com) which is mapped from the multisite domain name (domain.multsiteID.hosting.com). You can actually visit the www. version as well as the non-www. version as I have one redirected to the other.

    I did try to just place the domain.com/sitemap.xml inside of google webmasters and it was not successful. I actually tried it that way for a couple of sites since I wanted to make sure the issue was not with just one site.

    Please advise on this plugin you are referencing, how it works, and what changes we would need to make to every site to get it working. Is this our only option? Is there a way to fix InfiniteSEO to work as we need it to work for the sitemaps?

    Also, in the event you are not aware, I did provide all of the login information for you to view our multisite environment (admin dashboard and ftp) and the google webmaster tools environment. If you do not have them, please speak with David at your company who has been emailing me back and forth.

  • Ash

    Hello @David

    Thank you for your patience. Infinite SEO takes the URL from first install. Currently there are two ways to change this.

    Please check the accountantcoralsprings subsite. I have fixed the issue for you.

    If you have similar issues in other subsites, you need to use a little hack. Please download the attached file, open the file, go to line 242, change the url of that subsite, and upload to /wp-content/plugins/wpmu-dev-seo/wds-files/wds-sitemaps. Then refresh the sitemap settings page of that subsite. Once the url is changed, immediately delete 242, 243 and 244 and upload again.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers
    Ash

  • David

    Hi Ash,
    I followed your instructions exactly. I imported the file into Notepad++. I adjusted the link in line 242. I uploaded via FileZilla to the above referenced path (Once I was in the correct folder, I just placed the document there). I went back to the website, http://www.accountantinbocaraton.com's InfiniteSEO settings, went to Step 2. Sitemaps. Tried three things here: first I click on the Save Settings button at the bottom of the page. Nothing happened, site still displays with all the other information in the link. Second I tried just refreshing the page. Nothing happened, site still displays with all the other information in the link. Third, I tried clicking on another tab and then back to the Step 2 tab. Nothing happened, site still displays with all the other information in the link. Please advise on what is going wrong here. Your instructions state to verify the link before removing lines 242, 243, 244. I can't remove those lines and replace the file again because the file is still wrong.

    Thank you in advance for your assistance (again). I look forward to hearing from you!

  • David

    ***FOURTH REQUEST PLUS I HAVE SENT EMAILS TO YOU AS WELL***
    ***PLEASE RESPOND***

    I have still not received a response back from the posts to this thread. Ashok asked for me to email him the thread ID TWO DAYS AGO, yet I still have not heard back from him. I am including all of the information again in this posting. I need a response ASAP.

    Hi Ash,
    I followed your instructions exactly. I imported the file into Notepad++. I adjusted the link in line 242. I uploaded via FileZilla to the above referenced path (Once I was in the correct folder, I just placed the document there). I went back to the website, http://www.accountantinbocaraton.com's InfiniteSEO settings, went to Step 2. Sitemaps. Tried three things here: first I click on the Save Settings button at the bottom of the page. Nothing happened, site still displays with all the other information in the link. Second I tried just refreshing the page. Nothing happened, site still displays with all the other information in the link. Third, I tried clicking on another tab and then back to the Step 2 tab. Nothing happened, site still displays with all the other information in the link. Please advise on what is going wrong here. Your instructions state to verify the link before removing lines 242, 243, 244. I can't remove those lines and replace the file again because the file is still wrong.

    Also, in addition to above, I tried uploading the file in both .txt and .php files (separately and not without deleting the other first). Neither were successful.

  • Ash

    Hello @David

    Please check now. I did the same, just changed the url in my above attached file, upload, refresh the sitemap page, delete the following codes and upload again.

    $sitemap_options['sitemapurl'] = 'http://accountantinbocaraton.com/sitemap.xml';
    update_option( 'wds_sitemap_options', $sitemap_options );
    $sitemap_options = get_option( 'wds_sitemap_options' );

    Please let me know if any more issues.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.