Inifite SEO Keeps pulling my localhost Staging URL and not the LIVE URL

We recently launched a site we were staging locally and now our sitemap URLs look like this:

<url>
<loc>http://localhost:8888/law_network/contact-us/</loc>
<lastmod>2012-01-13T20:17:38+00:00</lastmod>
<changefreq>weekly</changefreq>
<priority>0.8</priority>
</url>

I tried re-installing the plugin, manually modifying the localhost instances in the sql, I just can’t seem to get Infinite SEO to update to the live URL. *Please note I ran the proper commands which updated the URL in the database for everything else.

I’m not sure what to do at this point. Any ideas?

  • Timothy
    • Chief Pigeon

    Hey dfathers.

    Sorry to hear about the issues you are having.

    Can you confirm that all instances of localhost within your database where changed that need changing and for every site in your multisite if you have ms setup?

    Can you also delete the sitemap.xml file located in:

    wp-content/blogs.dir/

    and the relevant folder for the site.

    Take care.

  • dfathers
    • Site Builder, Child of Zeus

    Hello Monthly,

    Thanks for your reply. I dont actually have Multisite setup. I removed the sitemap.xml file from the wp-content/uploads folder and reinstalled Infinite SEO. After the re-install the admin side kept throwing Internal Server errors, I had to remove the plugin in order to get our site back up.

    I’d like to use the plugin as it’s worked well in the past. Could I submit a support ticket somewhere so someone on the WPMUDev side could take a look?

  • dfathers
    • Site Builder, Child of Zeus

    Hi Timothy,

    Thanks for your quick response.

    Here’s from our error logs:

    [14-Jan-2012 19:45:14] PHP Fatal error:  Out of memory (allocated 13631488) (tried to allocate 107359 bytes) in /home/hiding/public_html/wp-settings.php on line 135
    [14-Jan-2012 19:45:14] PHP Fatal error: Out of memory (allocated 16252928) (tried to allocate 30720 bytes) in /home/hiding/public_html/wp-includes/admin-bar.php on line 122
    [14-Jan-2012 19:45:14] PHP Fatal error: Out of memory (allocated 2359296) (tried to allocate 7680 bytes) in /home/hiding/public_html/wp-includes/wp-db.php on line 1523
    [14-Jan-2012 19:45:14] PHP Fatal error: Out of memory (allocated 15466496) (tried to allocate 122880 bytes) in /home/hiding/public_html/wp-includes/class-http.php on line 1073
    [14-Jan-2012 19:45:14] PHP Fatal error: Out of memory (allocated 17039360) (tried to allocate 122880 bytes) in /home/hiding/public_html/wp-content/plugins/wordpress-importer/wordpress-importer.php on line 619
    [14-Jan-2012 19:45:14] PHP Fatal error: Out of memory (allocated 12582912) (tried to allocate 3 bytes) in /home/hiding/public_html/wp-includes/deprecated.php on line 1137
    [14-Jan-2012 19:45:14] PHP Fatal error: Out of memory (allocated 14155776) (tried to allocate 122880 bytes) in /home/hiding/public_html/wp-includes/taxonomy.php on line 1911
    [14-Jan-2012 19:45:14] PHP Fatal error: Out of memory (allocated 12582912) (tried to allocate 8 bytes) in /home/hiding/public_html/wp-includes/deprecated.php on line 1130
    [14-Jan-2012 19:45:14] PHP Fatal error: Out of memory (allocated 2621440) (tried to allocate 80 bytes) in /home/hiding/public_html/wp-includes/plugin.php on line 750

  • Timothy
    • Chief Pigeon

    Hey again :slight_smile:

    Those errors are telling you that you don’t have enough memory. You need to allocate more memory, you could ask your host to do this in php or you could do it.

    You could first try sticking this in your wp-config.php and let me know if it works:

    define('WP_MEMORY_LIMIT', '64M');

    You could up that to 128M or 256M to test.

    Take care.

  • dfathers
    • Site Builder, Child of Zeus

    Very strange, I updated wo-config to have this line

    define('WP_MEMORY_LIMIT', '256M');

    However we’re still getting this message when I try to save settings on the site map tab in the Infinite SEO settings:

    Fatal error: Out of memory (allocated 12058624) (tried to allocate 73728 bytes) in /home/hidden/public_html/wp-settings.php on line 133

    This could just be a more server specific issue?

  • Timothy
    • Chief Pigeon

    Can you please create a file, name it anything you like, perhaps phpinfo.php and stick the following in there:

    <?php
    phpinfo();
    ?>

    Then upload it to your server and access it through your browser. Check what the server memory limit is.

    You could try a php.ini file the following in:

    memory_limit = 128M;
    max_execution_time = 45;

    I think they explain themselves but the first is for memory, the second is for the time it allows for execution.

    Check it changed the setting properly by seeing it within the phpinfo.php file we mentioned above.

    you can keep upping the memory until it works, like 64M, 128M, 256M, 512M, etc, It shouldn’t need that much unless you use tons of plugins and have a busy site?

    This could just be a more server specific issue?

    The error is a server issue. PHP needs more memory.

    You could also ask your host for help on this one. Tell them you need to give php more memory. Most decent hosts will be accommodating and helpful :slight_smile:

    Let me know how you get on.

  • Timothy
    • Chief Pigeon

    Hey again.

    The error:

    Fatal error: Out of memory (allocated 12058624) (tried to allocate 73728 bytes) in /home/hidden/public_html/wp-settings.php on line 133

    Is always a memory issue which requires more memory. Allocating more memory always resolves this on our sites and our client sites.

    I’ll be checking e-mails shortly, if you haven’t already had a reply I’ll respond there.

    If you could include a link to your phpinfo file so I can see your php info.

    I’ll mark this as resolved seems you will be going through e-mail.

    Thanks.

  • dfathers
    • Site Builder, Child of Zeus

    Hi Timothy,

    I fixed the issue by basically re-install wordpress.

    That being said, I’m working on another site, moving it from a staging domain to the live domain, and can’t seem to figure out how to update the “URL to the XML Sitemap”. Does this have to be updated via the Database?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.