Insecure content in the browser console

I can see some Insecure content warning with some WooCommerce fonts but doesn't seem to solve.

  • Kasia Swiderska
    • Support nomad

    Hello SSO,

    It looks like it's related to Hummingbird CDN - when it's disabled the blocked assets where not there.
    I have reached out to the developer for their valuable opinion about this issue because I have tried clearing cache and re-checking files in Asset Optimization but without luck.
    I will let you know what is happening after developer will check it.

    kind regards,
    Kasia

  • SSO
    • New Recruit

    Since none of the multiple support people have been able to solve this and there are no updates to this day, we have no other choice but to remove WPMU from the site completely and cancel the subscription. I'm sorry, but the promised plugins did not work for us, but broke the site in weird ways completely.

  • Kasia Swiderska
    • Support nomad

    Hello SSO,

    I apologize for the inconvenience

    Our developer was checking your site and he found that this file prettyPhoto.css was causing this issue. They suggested that you exclude this file while they are still working on why this file was causing this problem.
    But if you remove plugin we can't move it forward :slight_frown:
    I understand your decision, but to investigate we need a plugin on the site.

    kind regards,
    Kasia

  • Calum Brash
    • Developer

    Hello SSO,

    I've excluded the file prettyPhoto.css which fixes your insecure content warnings (file shown in screenshot below).
    This file is a deprecated file from WooCommerce and because your theme doesn't use it, it's safe to exclude.
    The reason the URLs are being converted to HTTP could be from a number of things which we'll still investigate to prevent further instances of this happening. This could be from a plugin like Really Simple SSL or due to migrated settings from an HTTP site that didn't update settings.

    Cheers,
    Calum

  • SSO
    • New Recruit

    Hello,

    Thank you for resolving the insecure content warnings issue. What can I do on my behalf to help find out the cause of URLs being converted to HTTP? Should I remove the Really Simple SSL plugin?
    Also, should I open another thread concerning the issue that the site is still slow even with Hummingbird activated? It was a bit faster before adding the WPMU dashboard.
    Will be looking forward to your reply, thank you.

    • Calum Brash
      • Developer

      No problem :slight_smile:
      No need to remove the Really Simple SSL plugin, I was just trying to get across the point that it's difficult to work out what was causing the URLs to be converted to HTTP. If you could create a staging site that we could have access to this would help us have a play around without worrying about breaking anything on live.
      The WPMU Dashboard is a very small plugin and won't have any affect on your frontend speed. I noticed you don't have page caching turned on. This should help with your speed but there's only so much Hummingbird can do for your site before you have to look at upgrading your hosting.

      Cheers,
      Calum

  • SSO
    • New Recruit

    We have a staging site, you should have access to it (I have granted access for you to https://dev.streetshopone.ee/). We are very hesitant on turning on caching since it broke almost everything the last time we did it (also the reason why we can't use Smush Pro, it just messes up the site). Our hosting is genuinely maxed out by hosting experts, I can share the specs if you'd like.
    Please let me know, thanks again.

  • Calum Brash
    • Developer

    Hi SSO ,
    I was able to locate the issue as having your wordpress installation in a subdirectory and some .htaccess rules and constants set in your wp-config.php from an older caching plugin. This was causing Hummingbirds URL rewriter to revert the urls back to http. I've done the fixes on https://dev.streetshopone.ee/
    Please note that with these changes you will now login to the wp-admin at https://dev.streetshopone.ee/wp-admin note the removal of /sso_wp/

    Please let me know if you would like me to make the same changes to live for you, or give you steps on how you can do this yourself.

    Thank you for your patience on this,
    Calum

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.