insert google maps as shortcode

Hello;
I need to use your google maps plugin.
The thing is that The template I´m using (flexmarket) use "page builder" to build each page. So the option of inserting the google map in the traditional page I cannot use it. The other option is inserting it as a widget, but then I am forced to insert the widget in the footer and therefore the map is visible on every page, including home, not only in the contact page where I want it (see image attached).
I am thinking about inserting it in the page builder through a shortcode, but I need the shortcode for doing this. I tried just putting [map id="1"] in the shortcode area of the page buider but it doesn´t work.

  • zenware

    THANKS;
    This my flexmarket page builder for the contact me page.
    As you can see, I´m using a contact form, some blocks of text and a widget block to insert there the map, that is been taken from footer2 area, and this is why it is been shown in every page and I don´t want that. So I inserted at the right column the shortcode block to do some tests, but I didn´t manage to find the correct shortcode. Please note that at the "available blocks" column you are going to find a google map block, but this is not the one of wpmudev plugin, as it was already in the template prior of installing your plugin. I am not using this one because it is a static map, not a interactive map. It just shows a capture of google maps and this is not what I want.
    thanks!

  • Tyler Postle

    Hey Zenware,

    Hope you're doing well today and thanks for posting those screenshots :slight_smile:

    Is there only certain maps that you need? If that's the case then you can temporarily switch to a different theme, create your map shortcodes then switch back to your flexmarket theme and add the shortcodes in as needed.

    When you added in the [map id="1"] was that map already created, can you switch themes and paste it into a post and make sure everything is working correctly then copy and paste it into the page builder when you switch back?

    Also, is there any text vs visual box options on your page builder? Make sure you add it into the text one :slight_smile: if there isn't different options there then just add it into whatever is there.

    Let me know if this works or if this is what you already did. It could be that the page builder just won't run shortcodes, which is fairly common.

    Look forward to hearing back!

    All the best,
    Tyler

  • Michelle Shull

    Hi zenware,

    The shortcode you created

    [map id="1"]

    is correct, so it should work if your theme supports short codes, and if you have a map created that has an ID of "1." You can check this by going to your list of maps in the dashboard. If you hover over a map name, the URL for that map, with the map ID, will show at the bottom of your browser window. Make sure you have a map with an ID of "1." If you've made and deleted several maps, it could be that you've removed the map with that ID number, which would explain why that shortcode wasn't displaying a map.

    If that doesn't solve it, we may need support access to help suss up this issue. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.