Insights page unresponsive to sorting feature

My insights page (http://www.mcfrecognition.com/resources/), no longer responds to the 7 filters just below the hero. I believe this issue began after the recent wordpress update.

The visitor is supposed to be able to click one of the categories, such as EBOOKS, and the area is only supposed to display resources that are labeled EBOOKS in the resources area of the CMS. None of the tabs now work.

I granted access

  • Nithin

    Hi Cord,

    Hope you are doing good today. :slight_smile:

    There seems to be a JQuery conflict, which is due to the latest update to WordPress 4.5, causing an error in the console:

    Error: Syntax error, unrecognized expression: body.smooth-scroll a[href*=#]:not([href=#])
    Error: Syntax error, unrecognized expression: a[href*=#contact]

    Is it a premium theme?, if yes, updating to the latest version should fix this issue, would recommend you to contact your theme developer regarding this.

    You can fix this issue by replacing the existing code, by adding quotes to these expression in your files:

    body.smooth-scroll a[href*="#"]:not([href="#"])
     a[href*="#contact"]

    Please let us know if you need any further help. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Cord,

    Hope you are doing good today. :slight_smile:

    Since it's a customized theme contacting your theme developer would be the easiest option to get this sorted faster, since you no longer have contact, I would like to replace those code, and see whether it works, and if possible provide a temporary fix to it.

    Would you please send us your credentials so that we can have a closer look?

    You can send credentials by using our secure contact form http://premium.wpmudev.org/contact/

    Select "I have a different question” for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Cord,

    Hope you are doing good today. :slight_smile:

    I have made the following changes to the files in /wp-content/themes/mcf/js folder. The files edited are project.js, project.min.js, /concat/contact-model-init.js, /concat/smooth-scrolling.js. After making those changes the Insights page seems to work fine, and the sort feature is working as it's supposed to be. Please clear the browser cache to see the changes.

    I hope this helps. Have a nice day :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.