Instalation step forgotten. Add line add_global_table('ust');

I just noticed that I forgot to add the line add_global_table('ust'); to the db-config.php if using multi-db :slight_frown:
This needs to be done BEFORE installing Anti-Splog as per instructions.

Is there any way to fix this without re-installing anti-splog?

Thanks
Giorgos

  • Philip John
    • DEV MAN’s Apprentice

    Hiya Giorgos,

    You could try running the script again with the missing line added in.

    However, I can't guarantee that'll work straight off so do make sure you can do that in a test environment first, or at least take a backup.

    Otherwise you will need to roll-back and re-install.

    Thanks,
    Phil

  • giorgos
    • Design Lord, Child of Thor

    Thanks Phil, I just checked my db and there is already a table "ust" there, So I will skip and leave it as it is. If you have any explanation how the table was created at the first place is good to now, but otherwise consider it solved, as everything works fine.

    UPDATE: I suspect I installed anti-splog and later multi-db. As table was already created during antisplog instal at the single db and moved over with the move-blogs.php to the multi-db.

  • Barry
    • DEV MAN’s Mascot

    I just noticed that I forgot to add the line add_global_table('ust'); to the db-config.php if using multi-db

    It's an extra step that is recommended, but not required for use with multi-db.

    Multi-db will fall back to using the global database for tables that don't have blog id numbers in the table names, but the extra step of specifying the global table means that multi-db will identify the database to look in a few steps quicker than without it.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.