Install fails invalid header

Hi there we have been trying to install this plugin on wp 2.9.2 and a buddypress 1.2.4 installation but we continue to get a message that the header is invalid. We followed the instructions provided

Please advise

Thank you

Jake