Install upfront not working

Upfront does not seem to be working here the same thing applies to themes. Configuration does not work.
So far not particularly impressed with upfront..part of it is certainly down to my lack of familiarity with it but also the interface and lack of contextual support does not give one much confidence - plus the requirement to install upfront theme at web the root give the impression of upfront still being in beta.

Maybe you can help

David

  • Dimitris

    Hey there David,

    hope you're doing good and thanks for joining us!

    Upfront does not seem to be working here the same thing applies to themes. Configuration does not work.

    Could you please elaborate a bit more on this?
    Is there any specific setting that give you troubles? Or specific child theme? Please advise!

    Also, please grant us with temporary support access to the website in question so we can see these issues "in action". You can do so via WPMUDEV Dashboard plugin, no need to share credentials, as described here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4
    Let us know here in your next reply that access has been granted as we don't get any notifications about it.

    So far not particularly impressed with upfront..part of it is certainly down to my lack of familiarity with it but also the interface and lack of contextual support does not give one much confidence

    You can find our current documentation pages about Upfront here:
    https://premium.wpmudev.org/docs/upfront-and-themes
    Let us know if further assistance/guidance is needed here and we can follow-up in any questions you may have.

    plus the requirement to install upfront theme at web the root give the impression of upfront still being in beta.

    This is confusing me a bit. Could you further elaborate? Do you mean UF parent theme?
    It is true that all of our themes are actually UF child themes and UF parent theme is being installed automatically the first time you install a UF child theme.

    Warm regards,
    Dimitris

    PS. I can see that you're a WPMUDEV trialist, so you may want to have a quick read on "How Free Trial Work" (if not already): https://premium.wpmudev.org/docs/getting-started/how-free-trials-work/

  • Dimitris

    Hey David,

    I accessed your website, activated Upfront editor (/?editmode=true) and noticed a http error code 500 (Internal Server Error) in console log.

    Could you please access your server via FTP or another file manager, edit the wp-config.php file of this installation and insert the following line just above the /* That's all, stop editing! Happy blogging. */ comment
    define('WP_MEMORY_LIMIT', '256M');
    Ref: https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Also increase max_execution_time to a higher value, like 300, as described here https://premium.wpmudev.org/blog/increase-memory-limit/
    You may have to contact your hosting provider about this though, if you don't see any changes in WPMUDEV -> Support -> System Info [button] -> PHP [tab]

    Finally, edit the wp-config.php file once more, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and revisit Upfront editor page (/?editmode=true).
    By doing so, a /wp-content/debug.log file should be created.
    Simply download it, rename it to debug.txt and attach it here in your next reply.

    Warm regards,
    Dimitris

  • David

    Hi

    Thanks for your help we seem to be making progress. The .log file is attached converted to .txt as suggested!

    I had to make a number of changes to php.ini including max memory size limit.
    There still seems to be a problem with one of the files (I have not attempted to edit it) downloaded from your server:
    [02-Apr-2017 15:51:22 UTC] PHP Notice: This XML document is invalid, likely due to invalid characters. XML error: Undeclared entity error at line 11, column 24 in /home/devteamcouk/public_html/wp-includes/class-simplepie.php on line 1421

    Plus a string of PHP deprecated mysql_connect() warning which seem to need correction:
    [02-Apr-2017 15:52:09 UTC] PHP Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/devteamcouk/public_html/wp-includes/wp-db.php on line 1568

    The practical symptoms are that the page now does load and the top video attempts to play quite well but the remaining images are presented as randomly pixelated!

    Could this be due to the malformed xml file?

    Hopefully you will be able to assist me to close the remaining issues fairly soon.

    Thanks

    David

  • Dimitris

    Hey there David,

    hope you're having a beautiful day!

    I'm very glad to say that all console errors have been gone after increasing max_execution_time!

    I can see in WordPress tab of System Info admin page here though
    /wp-admin/admin.php?page=wpmudev-support&view=system#tab-wordpress
    that WP_MEMORY_LIMIT is still 40MB.
    Did you make the change in wp-config.php file as I mentioned in my previous reply? Please advise!
    If not, it doesn't seem to be necessary, but it may be a good choice anyway.

    There still seems to be a problem with one of the files (I have not attempted to edit it) downloaded from your server:
    [02-Apr-2017 15:51:22 UTC] PHP Notice: This XML document is invalid, likely due to invalid characters. XML error: Undeclared entity error at line 11, column 24 in /home/devteamcouk/public_html/wp-includes/class-simplepie.php on line 1421

    Plus a string of PHP deprecated mysql_connect() warning which seem to need correction:
    [02-Apr-2017 15:52:09 UTC] PHP Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/devteamcouk/public_html/wp-includes/wp-db.php on line 1568

    The PHP Notices and Deprecated messages you're getting in debug information, shouldn't result halting any procedure so it's safe to ignore them.

    The practical symptoms are that the page now does load and the top video attempts to play quite well but the remaining images are presented as randomly pixelated!

    These images are being pixelated automatically in your installation (rather than our demo and product pages here in our website) as you don't have the necessary license to use them.
    It's just there as reference.
    I was able to start Upfront and edit one image element of these in homepage.
    I uploaded a new image, resized it a bit and then saved my layout (Upfront) with no issue at all!

    Here you can find our documentation pages about Upfront, hope you'll enjoy the ride!
    https://premium.wpmudev.org/docs/upfront-and-themes/

    Take care,
    Dimitris

  • David

    Hi Dimitris

    " can see in WordPress tab of System Info admin page here though
    /wp-admin/admin.php?page=wpmudev-support&view=system#tab-wordpress
    that WP_MEMORY_LIMIT is still 40MB.
    Did you make the change in wp-config.php file as I mentioned in my previous reply? Please advise!"
    Extract from wp-config.php:
    // To Disable Debug logging comment out above block and uncomment next linepwd
    //define('WP_DEBUG', false);

    /* That's all, stop editing! Happy blogging. */
    define ('WP_MEMORY_Limit', '256M');

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    You mention "MB" but I thought MB had to be written as M for PHP?. Does that apply here or have I made an incorrect entry?

    I did check:
    http://www.devteam.streeties.co.uk/wp-admin/admin.php?page=wpmudev-support&view=system#tab-wordpress
    and that does show 40M despite the entry in wp-config.php for which permissions are -rw-r--r-- with correct ownership. Any idea why there should be a difference. (The server has been restarted many times since the file was updated).

    If it helps temporarily http://www.devteam.streeties.co.uk/test.php gives results of phpinfo().

    "Here you can find our documentation pages about Upfront, hope you'll enjoy the ride!
    https://premium.wpmudev.org/docs/upfront-and-themes/"

    Do you have a download link to get all the documentation in a single pdf download? Would be very useful for working/making notes and sharing during development. I find online docs are often not the best way to go for working purposes when you need to look at several pages at the same time -- and they take up too much screen real estate!!

    Many thanks

    David

  • Dimitris

    Hey there David,

    you can use the code tag here in our forums, this way we can be sure for no formatting errors.

    You mention "MB" but I thought MB had to be written as M for PHP?. Does that apply here or have I made an incorrect entry?

    Could you please try to replace

    /* That's all, stop editing! Happy blogging. */
    define ('WP_MEMORY_Limit', '256M');

    with

    define('WP_MEMORY_LIMIT', '256M');
    /* That's all, stop editing! Happy blogging. */

    Ref: https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Do you have a download link to get all the documentation in a single pdf download?

    I'm afraid there's no downloadable file(s) for our docs and you should stick with our webpages.
    You're free to propose anything though, Features & Feedback section is the right place for that.

    Warm regards,
    Dimitris

  • David

    Hi Dimiris
    "I'm afraid there's no downloadable file(s) for our docs and you should stick with our webpages.
    You're free to propose anything though, Features & Feedback section is the right place for that. "

    Oh I tried using Acrobat Pro DC and now have compiled a single *.pdf file with all the docs in one file.

    Let me know if you want a copy.

    It means I can use the docs off-line
    I can add my own personal notes and examples to every page.
    I can easily print out any combination of pages I need.
    Quite a useful tool

    David

  • Adam Czajczyk

    Hi David!

    Great work with PDF I'm sure some other members of our community will find that useful and since you already posted it as a feature suggestion, I believe other members will also vote for including similar docs on our site.

    As for an initial issue. Did you make the change suggested by Dimitris here: https://premium.wpmudev.org/forums/topic/install-upfront-not-working#post-1240115

    Let me know if it helped and/or if you need further assistance with this, please.

    Kind regards,
    Adam