install WP on a PC and access it from other PCs and smartphones on a LAN using a domain name

My goal is to have a WP site I can bring with me on a location where there is no Internet connection, and to be able to share this WP site with other people in this location.
This is for a trainer and his WP site is hosting courses and quiz and he wants the attendees to access the courses and answsers the quiz.

Here is what I have done so far on my netbook running on Windows 10:
Install USBWebServer (http://www.usbwebserver.net/en/), so I have Apache, PHP, MySQL and PHPMyAdmin on a USB key connected to my netbook.
Install OStoto HotSpot (http://www.drivethelife.com/free-wifi-hotspot-creator.html), to use my netbook as a Wifi hotspot.
Modify my host file with entry: 127.0.0.1 local.cms
Setup a virtual host on USBWebServer in apache2/conf/extra/httpd-vhosts.conf, with, as my site is in root directory;
<VirtualHost *:80>
DocumentRoot "E:\USBWebserver v8.6\root"
ServerName local.cms
</VirtualHost>
Install WordPress with WordPress URL and site URL set to "http://local.cms/wptest01"

Here is what I have done on my Android Phone:
Connect to the hotspot of my netbook.
Define a proxy server with IP adress set to the IP adress of my netbook Wifi network card emulated by OStoto HotSpot.

With all that set:
From my netbook:
I can access PHPMyAdmin locally using http://local.cms/phpmyadmin/, and the whole site works fine.
I can access my WP site locally using http://local.cms/wptest01, and the whole site works fine, including admin.
From my Android Smartphone:
I can access static HTML pages such as http://local.cms/test.html, it works fine.
I can access PHPMyAdmin using http://local.cms/phpmyadmin, and the whole site works fine.
But unfortunately, I cannot access my WP site using http://local.cms/wptest01: I have no response from the netbook, and I have no errors in Apache error.log.

So this seems specific to WP since static pages as well as PHPMyAdmin works fine.

Here is the content of the .htaccess for wptest01:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wptest01/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wptest01/index.php [L]
</IfModule>

# END WordPress

I'm on this for almost one week, thanks in advance for your feedback.

  • Adam Czajczyk

    Hello @Luce Tancil,

    I hope you're well today and thank you for your question!

    I'm not familiar with USBWebServer and OStoto HotSpot but according to your description these seem to be working fine. I wouldn't say however that the issue is WordPress specific as you're able to visit the page from your localhost. This would mean that the WordPress itself is running fine.

    What I noticed here is that except phpMyAdmin which is (I think) bundled with USBWebServer and was pre-configured (running "out-of-the-box") the notable difference between those static pages and WordPress is that the latter resides in a sub-folder rather than the root folder.

    Have you already tried, just to check things out, installing WP in root folder of "local.cms" domain and putting static pages in a sub-folder?

    I'm asking this because it looks like something was affecting this sub-folder content. I'd also like to ask you to try one other thing: could you change the "local.cms" part in your WordPress URL and SiteURL to your netbook's IP (so it would be like "http://XXX.XXX.XXX.XXX/wptest01/") and then try to access it from other computers or your phone via this IP?

    Hopefully this step would provide us with some more debugging information, so I'll be able to find a solution for you.

    Best regards,
    Adam

  • Éric Malalel

    Hi Adam, I have made one of the test you requested.
    I can access http://local.cms/test.html from my netbook and from my Android device.
    I cannot access http://local.cms/wptest01/test.html, neither from my netbook, nor from my Android device.
    So doing this test was a very good idea, Adam.
    Problem is not related to WP, since even static pages are not served from the web server.
    Unfortunately, I need to host my WP in a subdirectory, since once this WP site will run, the next step will be to host on my netbook a copy of a production WP site which is hosted on a subdirectory.
    Can you give some advice on how to correct this subdirectory issue, based on this first test?
    Thanks in advance.

  • Éric Malalel

    Ignore previous post, I can access http://local.cms/wptest01/test.html from my netbook and from my Android device.

    I have installed WP in Apache root folder. Same problem, I can access it from my netbook, using http://local.cms, but nothing is displayed from my smartphone.

    I have then changed URL of WP site installed in root folder to IP adress instead of local.cms. Same problem, I can access it from my netbook, using http://192.168.202.1, but nothing is displayed from my smartphone.

    I have made further tests using Chrome debugging tools. It shows an infinite redirect loop when I want to access my WP site. You can see a screen copy attached. I have made this test from another netbook connected to the wifi hotspot of the netbook which hosts my WP site, using a proxy with IP address set to IP address of network card of Wifi Hospot, so same configuration as my Android smartphone.

    If we can fix this redirect loop issue, I think we should be good.

  • Adam Czajczyk

    Hello Luce,

    Thank you for additional information. I run additional tests, mostly following your setup.

    - I downloaded USBWebServer
    - I installed WP inside /wptest01 folder

    At this moment I was able to visit this site from my local machine.

    - I then downloaded the hotspot soft and run it
    - and connected my phone via IT

    Unfortunately, I do not have at hand an Android box at the moment and it turns out that I'm not able to access URLs including port numbers (I didn't change the default 8080 port). Luckily Opera Mini browser seems to support it however - again - shows limited connectivity.

    I then connected from another laptop to hotspot and actually was able to visit the site. What's worth noting here that I did not setup local domain, I left webserver running on default 8080 port and I didn't change WordPress URL and SiteURL (defaults: localhost so when I visited it via IP number it loaded no styles).

    That said, I got back to your initial post and also took another look at the screenshot you attached to your last post. What I'm thinking would be worth trying would be to adjust Virtual Host config a bit:

    <VirtualHost *:80>
      ServerName local.cms
      ServerAlias http://www.local.cms
      DocumentRoot "E:\USBWebserver v8.6\root"
      DirectoryIndex index.php
      ErrorLog "path_to_error_log_file"
    </VirtualHost>

    That'd be first step. Notice the "DirectoryIndex index.php" setting and error log. The first one tells Apache explicitly to look for index.php first and the second one should put all errors to a file. This may be helpful for diagnosing errors.

    Second step would be to switch WP back to

    WordPress URL: http://local.cms/wptest01
    Site URL: http://local.cms/wptest01

    Would you give it another try and let me know if it helped?

    Best regards,
    Adam

  • Éric Malalel

    Hi Adam.
    I have setup vhost as you mentioned, reset wordpress urls as you mentioned, but the problem is still there.
    No problem to access the WP site from netbook using http://local.cms/wptest01.
    Unable to access the WP site from Android using the same URL.
    I have attached my Apache config file and error log file.
    You will see in the error log that I first test from my netbook (client IP is 127.0.0.1) and then from my smartphone (client IP is 192.168.201.2).
    Android Wifi connection is set to my wifi hotspot and uses a proxy defined on IP 192.168.201.1, which is the gateway IP of the Wifi hotspot.
    I am not an Apache guy (my productions sites are hosted on IIS 8.5), but from what I read in the error log, it sounds there are also redirect errors when I access the site from my netbook, although it displays fine. Am I right on this point ?
    Hope these additional information will help you resolve this issue.

  • Adam Czajczyk

    Hello Luce,

    Thanks for your response and for sharing your log file with me. Although I done some Apache setups in the past I 'm not that much into Android/virtual hotspots subject. However, apart from those redirects there's one thing that bothers me a bit and it's a "generate_204" line in your error log.

    According to what I've found on the Internet it's some kind of probing used by Google services (therefore including Android but also some other apps and soft) to determine whether the network is "open", "close" or behind "captive portal". I'm not sure how this may be relevant but I never encountered this in my own network at home although I'm and I was using different devices (including Android tabled and phone in the past).

    I'm not saying this IS the reason for your setup not working but this together with re-reading your posts once again made me thinking about that proxy setup you're using. As I mentioned before, I tried to mimic your setup on my own network and both USBwebserver along with hotspot soft didn't require me at all to setup any proxy settings both on my another computer and my smartphone. Just connecting to the hotspot created by OStoto HotSpot (the same way as I would connect to any other available WiFi network or hotspot created by any mobile device) allowed me to access server resources (including /wptest01/ WP install).

    I realize I'm not giving you any conclusive answer yet and I apologize for that but that's quite a specific case scenario.

    Best regards,
    Adam

  • Éric Malalel

    Hi Adam.
    The virtual network card opened by OStoto has an IP address.
    If I use this IP address as site address URL and WP address URL, and if I define no proxy in the Wifi connection to OStoto used by my Android device, I can access the WP site and it displays (almost) fine.
    BUT this IP address is not fixed. Sometimes it is 192.168.201.1, and sometimes 192.168.202.1.
    SO some URLs are broken. You mentioned the CSS, I have same problems with some media files inserted on pages when IP address was 192.168.201.1, and no longer displayed when 192.168.202.1.
    That's why I want to use a domain name for this WP site, knowing that, the final use is to duplicate a production site which uses a domain name and has a lot of URLs using this domain name.
    And as far as I know (but I don't know everything), defining a proxy on the Wifi connection seems to be the only way to have this domain name resolved by my netbook, and not by Google DNS servers.
    So we may consider this is a DNS issue.
    But on the other hand, I only get the problem with WP. Static pages and even phpmyadmin works well with "local.cms" domain.
    Another info: when I connect to OStoto Wifi hotspot with no proxy, the Wifi icon on my smartphone is clean. When I connect with the proxy, it works (except for WP site), but it is displayed with an exclamation mark.
    Hoping you can provide additional feedback to this WP/DNS issue.

  • Adam Czajczyk

    Hello Luce!

    Thanks for your replay, I think we're heading closer now.

    I think there are two important things to notice here:

    1. Apache local domains would be "local" only within the same network...
    2. where by "the same network" we should consider what's withing the same network IP range

    The IP of hotspot changes and as you mentioned it's sometimes 192.168.201.1 and sometimes 192.168.202.1.

    Setting up an IP of hotspot to be fixed could be solution here I think but unfortunately I couldn't find a way to do this with this particular software. That said, have you considered other applications?

    From what I can see Connectify's Hotspot may be a way to go as it features a nice "Bridging Mode":
    http://www.connectify.me/hotspot/bridging-mode/

    With this mode its "automagically" making connected devices part of the same network your "hotspot computer" is in so it should solve the "local domain" issue. I haven't had a chance to test it yet but sounds like a good deal.

    Other than this, I admit I'm not sure what else could we do here and that's starting to go a bit beyond the scope of this forum. In case you'd need further assistance, let me know and I'll ask my colleagues here that deal with servers if they have any ideas on this but please note that I cannot guarantee they'll be able to help or respond in a timely manner.

    Best regards,
    Adam

  • Éric Malalel

    Hi Adam.

    I first tried Connectify, but it is not supported on Windows 10, and my netbook is already upgraded in Windows 10, which is supported by OStoto Hospot.
    But everything is fine since I found the solution.
    I connect my Android device on the Wifi hotspot of my netbook, and I define I want to use a proxy for this connection.
    But, although it works for all sites except WP sites, i.e. I can access them using domain "local.cms", there was no proxy software installed on my netbook, which sounds strange to me.
    So I installed Fiddler, available at http://www.telerik.com/fiddler, which acts as a true proxy server.
    I configured Fiddler HOST remapping so that any request to "local.cms" is redirected to 127.0.0.1, the local IP address of my netbook, and bingo, it works perfectly.
    Now I can make a copy of a production WP site hosted on "www.mydomain.com", bring it with me on my 128 Gb USB stick, and share it from my netbook with other users in the same room as "www.mydomain.com", even if there is no Internet connection.

  • Adam Czajczyk

    Hello Luce!

    I didn't realize that Connectify do not support Windows 10 yet, thank you for this information. That said, I'm glad you were able to find a solution and thank you very much for sharing this with us.

    This issue is surely quite uncommon and I'm pretty sure that it would be difficult for anyone to find a simple way to go. Therefore I think your solution will be of great help to some members of our community!

    In case you had any other questions, please do not hesitate to ask and start new threads on our forum!

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.