Installation

I activated the plugin, but there is no “Listings” section to configure the settings in the Admin bar. Please advise. Thanks!

  • HCE
    • WPMU DEV Initiate

    Thank you for responding! I reviewed that link before I posted here and I didn’t see anything on that page to help me with this issue. I installed the Directory plugin and there is nothing on the dashboard to configure the settings to set-up the directory.

  • HCE
    • WPMU DEV Initiate

    Thanks again, MTB1701! But that’s a different issue than what I’m having. They apparently can’t see their listings on their website. My issue is that the “Listings” tab in the WP Dashboard, where I can configure the settings for this plugin, is missing. I can’t even configure this plugin and create a listing b/c there is no tab in the WP Dashboard to edit the plugin settings.

  • Mark Wallace
    • Learn-ing-er

    Ok you may have a conflict with another plugin, also if you updated to 3.4 then it could be that as well. What you can do is switch to you 2011 theme >>deactivate all your plugins >>then reactivate the directory plugin. If this corrects the problem then start reactivating the other plugins one at a time, to check for a conflict. If this does not correct the problem then you will need to wait for a more experienced member to help you. Also by chance are you using the classifieds plugin with the directory plugin? Thanks HCE

  • 3SixtyEvolve
    • New Recruit

    Greetings HCE and welcome to our Community.

    Thank you to Mark for keeping you company and providing some link support to you while you were waiting. Don’t we have an amazing Community – members helping each other :slight_smile:

    HCE, I had this problem a while ago when I had the Classifieds Plugin activated with the Directory Plugin. However, this problem has been resolved and they are working perfectly in harmony now.

    Now let’s see if we can get this resolved. Please go to the wp-content/plugin folder via your FTP client and rename your plugins folder to something else. Then please copy all plugins, except for the Directory and the Classifieds (if you have it installed) and copy it into a new folder and name this folder ‘plugins‘. Now install the latest version of Directory (and Classifieds, if you are using it too) again via the FTP client.

    Please see if this will resolve the problem for you.

    Something else that I just want to confirm. Are you running on Multisite or single WP installation? If you are running on Multisite you would need to Network Activate the Directory Plugin to make it accessible to your network of sites.

    Hope to receive your feedback soon and to get this matter resolved for you.

    Have a great day!

    Gina

  • Mark Wallace
    • Learn-ing-er

    I would first go through the steps i pointed out. This will give you the best options. If that does not work then uninstall the classifieds plugin and try. I remember having a problem with directory and classifieds, but I never really looked into it, because I was just killing time while involved on another project. Also be sure to include wither or not you updated to 3.4 Thanks HCE

  • HCE
    • WPMU DEV Initiate

    Hi Gina!

    Yes, it was nice having Mark respond so quickly and enthusiastically. (Thanks again, Mark!)

    I have the Classifieds plugin installed, but it is NOT activated. I am using Multisite. I network activated the Directory plugin, and there are no options in my dashboard to configure it. Also, the Directory plugin is causing an error on my site. The error is as follows:

    “Warning: Missing argument 2 for Directory_Core::filter_list_pages() in /home/thunte17/public_html/eldllc.com/wp-content/plugins/directory/core/core.php on line 140

    Warning: Missing argument 2 for Directory_Core::filter_list_pages() in /home/thunte17/public_html/eldllc.com/wp-content/plugins/directory/core/core.php on line 140″

    What do you think the problem is?

  • Mark Wallace
    • Learn-ing-er

    Hi HCE

    As far along as you are with this; Gina has probably sent the error messages to the lead developer. Sometimes it takes a while. Everyone is in different time zones, and have other problems they may be working on. They will get it done for you. 3 things i do while waiting:

    1. Look through the forums to see if I can help anyone with simple problems; this frees up the staff to address larger issues, like the one you are having.

    2. I look for other plugins I will need for various projects.

    3. I work on a current project; for example: This would be a good time to type out you directory listings. Then you can copy and paste them latter, or just work on other content of your website.

    These things make the wait a lot easier. Its kind of like watching the tea pot boil. <<<Not Fun.

    Thanks HCE

  • Mark Wallace
    • Learn-ing-er

    If you check her location it reads: Dubai, United Arab Emirates; It’s probably bed time there. You’re probably like me and only take cat naps, then back to work. The staff deals with there a lot of people all day, and work on their own projects. I feel your pain on this. When i first joined the community, didn’t understand these things. I thought it was all about me. Then i learned that a lot of the staff are volunteers, and unfortunately the require sleep. lol

    I bet she has the “Be notified of follow-up posts via email” and will address this when she returns. After all it’s probably in the hands of the lead developer, or another staff member would be in here until it’s marked resolved. I’m following this because I too will be using the directory plugin in a few weeks. Then you can help me. :slight_smile:

  • 3SixtyEvolve
    • New Recruit

    Hi HCE

    I am sorry for the delay in getting back to you.

    Yeah, different time zone doesn’t always help when a member is waiting for an answer. And believe me, I wish I can be on here 24/7 to support our members, but a girl needs her beauty sleep too, right :slight_smile:

    Ok, back to your problem.

    I have asked the Developer to look into those error messages, but in the meantime, if you would like me to check the WP Admin to see if I can find any other reason why you’re getting these errors, you’re welcome to forward an access for me to gina@incsub.com.

    I will look out for an email or post from you. Talk soon.

    Gina

  • 3SixtyEvolve
    • New Recruit

    Thank you Mark, for showing your support and for your vote of confidence in us.

    We are a dedicated bunch, but we are also human and thus, we might not always be able to make everyone happy. But we sure do try… :slight_smile:

    Have a wonderful day.

    Gina

  • Arnold
    • El Macho WP

    Hi all,

    One thing that may be happening on Multisite is you need to allow subsites in the CustomPress settings. Login in as Super admin and tick the subsite checkbox in CustomPress settings.

    And yea it’s abut 6 in the morning and my cat just woke me up. :slight_smile:

  • 3SixtyEvolve
    • New Recruit

    Thank you Arnold for your fast assistance on this one. Appreciate it so much.

    I have that too. But mine wakes me up in the middle of the night, not in the morning, LOL :slight_smile:

    *****

    Hi HCE

    Let me know if the feedback from Arnold got you sorted or if you need further assistance.

    Talk soon.

    Gina

  • HCE
    • WPMU DEV Initiate

    Gina,

    This issue is still NOT resolved. This is very disappointing. Mark’s nor Arnold’s suggestions addressed my issue, and none of your responses addressed my issue either.

    As I stated above, when I activated the Directory plugin, the tab in the WP dashboard labeled “Listings” does not appear. There are NO options in my dashboard to configure the the Directory plugin and set-up my directory. Nothing here specifically addresses that.

    Moreover, as I also mentioned above, I’m getting an error message on my web site about a “missing argument” in the Directory core.php file. Nothing here address that either. You stated that you would forward this error message to a developer, but to date I have not heard back anything.

    Again, I am very disappointed about the inefficiencies in the level of “support” I’ve received here. I hope this matter will be addressed competently and immediately, or I will have to cancel my membership and request a full refund, as my sole purpose for signing up was for this Directory plugin and it is not working, nor have I been able to get competent and effective support for it in over three weeks.

  • Arnold
    • El Macho WP

    That’s why I brought up the CustomPress settings. Directory and CustomPress work together, That’s why they are supplied together, so settings in Custom Press apply.

    On Multisite you need to go to the Network Admin dashbosard and in CustomPress settings set the “Enable sub-site content types.” and “Display the network-wide content types on sub-sites.” This was metioned above but we never got a response.

    I’ll be glad to look at your setup if that still doesn’t get it. I would need an admin and FTP login to your site to take a good look. You can email me the logins at arnold at incsub dot com.

  • HCE
    • WPMU DEV Initiate

    Arnold,

    The “Enable sub-site content types.” and “Display the network-wide content types on sub-sites.” in the Custom Press settings are both enabled. That is not the issue.

    Did you look at the error message I noted above? I keep getting an error message on my site about a “missing argument” in the Directory core.php file. Please respond specifically to that.

    Thank you.

  • Arnold
    • El Macho WP

    The filter_list_pages is a standard filter on wp_list_pages. So to fail it would be something in WordPress or your theme. The plugin never calls it, it just adds the filter so wordpress will call it. If wordpress is not passing the 2 argument I’d need to dig around your install and see why.

    I offered to do this in the previous message. Still glad to take a look.

  • PC
    • WPMU DEV Initiate

    Hello Everyone !

    Thanks a lot for your support on this one.

    I am marking this post as resolved as the original requester is no longer an active member.

    Should anyone have any questions, please feel free to re-open or create a new thread.

    Cheers

    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.