installed classifieds plugin and setup as per instructions.

Hello, installed classifieds plugin and setup as per instructions. When view "classifieds" page get Not Found

"Apologies, but no results were found for the requested classifieds. Perhaps searching will help find a related classified."

As i understand this page is autogenerated.
Also, after buying credits successfully when user clicks on"create new classified" the page just refreshes.

So, what is happening please? thanks. And don't ask me to deactivate all other plugins one at a time please to see if there is clash :slight_smile:

had a reply from - Vaughan
6368 points
SUPPORT SQUIRREL (joined February 2013) Likes (0)
Hi @tosca_lahiri

Can you try going to Dashboard > settings > permalinks

set to post-name. But any setting should do except for default. it will not work with default. Try regenerating the permalinks.

Hope this helps.
------------------------------------------

But this hasn't fixed the issue. Also, why can't I reply to Vaughan at https://premium.wpmudev.org/forums/topic/why-is-the-classifieds-page-showing-not-found-error#post-555595

Thanks

  • Vaughan
    • Support/SLS MockingJay

    Hi

    Not sure why you can't reply on that thread.

    Have you tried clearing browser cache/cookies and logging out/logging in again? Or try with a different browser.

    Occasionally this happens unfortunately.

    I'll mark the other thread as resolved and we can continue here.

    Can I ask if the classifieds listings that have been submitted are actually published? or are they set to draft or pending review? Go To Dashboard > classifieds > classifieds page.

    Look at the title for each classified and see if it says draft or pending.

    If it says either, you can edit the listing and change from draft to publish.

    Can you also try switching to the default 2012 theme and see if they appear then?

    Hope this helps

  • DavidM
    • DEV MAN’s Mascot

    Hi there,

    We received your email and have responded to that. I'll work alongside Vaughan on this and see if we can't get this sorted quickly.

    Could I just ask one thing to start with?

    Could you please try disabling other plugins for just a moment, and then testing to see how that listing creation process goes?

    That will help us to know if this is related to a plugin conflict, which seems likely to me.

    Thanks,
    David

  • DavidM
    • DEV MAN’s Mascot

    Hi Tosca,

    Thanks for sending through your site details and allowing us to work with you on this. I just wanted to mention this for other members experiencing the same issues.

    This centered around capabilities, which can be customized at Classifieds > Settings > Capabilities or as follows:
    yoursite.com/wp-admin/admin.php?page=classifieds_settings&tab=capabilities

    Users will see and have available only the options that you allow them via their user role's capabitlies there. It's a great feature of the plugin to be able to control what the users see on a user role basis. It could also potentially lead to undesirable consequences if you're not aware of the settings.

    Given the user roles capabilities that allow them to see/edit listings will then allow them to see/edit them. Otherwise they'll see what looks like errors.

    Thanks again for allowing is to assist in sorting this. Please let us know any further questions that might come up. :slight_smile:

    Cheers,
    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.