Installed CoursePress Pro V2.0 and entire platform is not working

Please help! I have just installed V2.0 of CPP tried creating a course with units to test the new functionality and it looks like it's fallen over... oops in fact my whole site which uses the CPP plugin is not working/reachable. I've granted admin/login access for you, please could you take a look? Thanks

  • Adam Czajczyk

    Hello Evology,

    I hope you're well today and thank you for your question!

    I accessed your site and I see that the front-end returns an error message saying that "The theme directory "coursepress" does not exist.". This suggests that the "CoursePress" theme is enabled but it's not available.

    I then checked "Themes" settings of your main site and noticed the same: the CoursePress theme is set to active but apparently it's not fully installed.

    The CoursePress theme comes bundled with the CoursePress plugin and since it is active, you must have had tried to used it and either something went wrong or you removed/renamed some parts of it. That's a bit unexpected and strange issue I must say and I didn't came across it before.

    The basic action would be as follows:

    1. Go to the "Themes" page in a dashboard of your main site and select any other theme than CoursePress, setting it to active. This should bring back the site. The CoursePress plugin doesn't have to be used with "CoursePress" theme and you can use any other theme with it.

    2. If you wish to further test "CoursePress" theme, please access your server via FTP (or cPanel "File Manager") and make sure that you copied entire "coursepress" folder from inside the "/wp-content/plugins/coursepress/2.0/themes/" folder to the "/wp-content/themes" folder

    I hope that helps!

    If you have any additional questions, let me know please.

    Best regards,
    Adam