Installed Hummingbird and Defender

I installed Defender and Hummingbird on my multisite, after I installed the I got a fatal error warning. I have a php ini file set to:
upload_max_filesize = 2000M
post_max_size = 4000M
memory_limit = 6000M
file_uploads = On
max_execution_time = 360

But it showed it was coming from hummingbird so I deleted the plugin and than got the same error from defender. So I checked my .htaccess file and hummingbird rewrote that file to this:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

</IfModule>

# BEGIN WP-HUMMINGBIRD-GZIP

<IfModule mod_deflate.c>
<IfModule mod_setenvif.c>
<IfModule mod_headers.c>
SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
</IfModule>
</IfModule>
<IfModule mod_filter.c>
AddOutputFilterByType DEFLATE "application/atom+xml" \
"application/javascript" \
"application/json" \
"application/ld+json" \
"application/manifest+json" \
"application/rdf+xml" \
"application/rss+xml" \
"application/schema+json" \
"application/vnd.geo+json" \
"application/vnd.ms-fontobject" \
"application/x-font-ttf" \
"application/x-javascript" \
"application/x-web-app-manifest+json" \
"application/xhtml+xml" \
"application/xml" \
"font/eot" \
"font/opentype" \
"image/bmp" \
"image/svg+xml" \
"image/vnd.microsoft.icon" \
"image/x-icon" \
"text/cache-manifest" \
"text/css" \
"text/html" \
"text/javascript" \
"text/plain" \
"text/vcard" \
"text/vnd.rim.location.xloc" \
"text/vtt" \
"text/x-component" \
"text/x-cross-domain-policy" \
"text/xml"

</IfModule>
<IfModule mod_mime.c>
AddEncoding gzip svgz
</IfModule>

</IfModule>
# END WP-HUMMINGBIRD-GZIP
This was after hummingbird was deleted. So I deleted the defender plugin and site operates normally. What is the problem here and how can I fix this. Love the idea between the 2 plugins but not sure what I am doing wrong!

  • Rupok

    Hi Ruppert Marketing, hope you had a wonderful day.

    Actually it's pretty tough to conclude about the reason behind this without seeing the *exact* fatal error you were getting. Can you share the error with us? That will give us valuable insight on this.

    From your modified .htaccess file, I can see, you turned on GZip Compression and some other stuffs. Did you get that fatal error after enabling any feature or just after installing Hummingbird? Are you running Apache or Nginx in your server? Did you select the right server type while enabling features in these plugins? I'm running both the plugins side-by-side on my test site but I'm not facing anything like this.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Is this a LIVE site or we are allowed to make some modifications if necessary? Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Moreover, can you please send me message with FTP Access Credentials through our secure contact form here: https://premium.wpmudev.org/contact/ ? Please take a full backup of your site before you send these info to us so you can always revert back to current state if anything goes wrong.

    Subject: "Attn: Rupok"
    - FTP Username
    - FTP Password
    - FTP Host
    - Link back to this thread for reference
    - Any other relevant URLs

    Select "I have a different question" for your topic. This and the subject line ensure that it gets assigned to me.

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Ruppert Marketing

    Actually it is a site I have to have to show to a client by tomorrow. But tomorrow I will setup another site exactly the same and see if I get the same error. The server is an apache and yes it was after I set the settings. I closed it out without saving the error so im not sure of the exact error. I am sure it was an error on my part i get over zealous and jump in without looking at the specifics until something breaks lol. Appreciate the quick response.

  • Rupok

    Hi Ruppert Marketing, hope you had a wonderful day.

    I do apologize for delayed response. Actually we have quite a few queries from our users and we answer on "first post first reply" basis. Users who have replied earlier are supposed to get replies earlier. I actually broke the sequence and replying here.

    Well, the error notice clearly indicates that your server is running out of allowed memory. You can try the following to fix it:

    1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '128M');

    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 64M try 128M:
    memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)

    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 128M

    4. Talk to your host.

    Please let us know if your issue is still not resolved. We will be glad to investigate further.

    Have a nice day. Cheers!
    Rupok

  • Ruppert Marketing

    Totally understand that was not upset just didnt want you guys to waste your time going to the site it was just a shell so it was not a big loss rebuilding now and so far so good. As far as the code above I had already done that. I do that to every site before I start building to be sure I have enough power. I think i screwed up with the hummingbird not sure though. Will read through the instructions more clearly this time! Thanks for your guys time you all rock!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.