Installing MU plugins

On my site http://www.carobowl.com I was trying to install the 'Remove Email Verification From Signup' plugin. I read that this MU plugin is now OK with Buddypress. Even after reading all the instructions I can not install this plug. Do I still create an extra folder named MU plugins in Buddypress? I have read the readme page but am confused which unziped file goes were. Which folder do I put it in for my non MU BuddyPress?.

Please help with which file to transfer into which folder via FTP.

Please help

  • Sue

    @Aphrodite thanks for helping.

    @myemedia for a step-by-step explanation, with screenshots, of what @Aphrodite is saying refer to our information on setting up your mu-plugins folder and installing mu-plugins here - https://premium.wpmudev.org/wpmu-manual/using-mu-plugins/

    You will find information on which file to transfer on the plugin installation page here - https://premium.wpmudev.org/project/remove-email-verification-from-signup/installation/

  • myemedia

    Thanks for the update - I read all the instructions again that you suggested above and tried all the steps but it is still not removing that required email activation stage. I have tried this plugin on both a test site and the real site without it working. I tried removing all other plugins and still no luck.

    I understand that when the files are loaded in the MU-plugins folder a MU-plugin did not need activation as it was site wide when added to the correct folder. A surprising thing is that in the WP admin plugin menu, I now have the option to activate the following plugin. But which I tried to activate it no luck. This plugin appeared in my list of plugins on my real account but not on my test account. It read as:

    Remove Email Verification
    This plugin automatically activates user and blog signups, effectively disabling the need for the user to respond to an email
    Deactivate | Edit
    Version 1.0.3 | By Barry at clearskys.net (Incsub)

    I did try activating it just in case and then I got the following error:

    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Cannot redeclare remove_bp_activation_emails() (previously declared in /home1/mywebnet/public_html/carobowl/wp-content/mu-plugins/remove-email-verification.php:42) in /home1/mywebnet/public_html/carobowl/wp-content/plugins/remove-email-verification-from-signup-1.0.3/remove-email-verification.php on line 50

    Hope you may be able to help please

  • Mason

    Hiya myemedia,

    I set up a test user on your site and found that the activation email is still required. On this plugin's project page it doesn't list BuddyPress compatibility. It may be a mistake, but I'm wondering where you read that this plugin was now BuddyPress compatible.
    https://premium.wpmudev.org/project/remove-email-verification-from-signup

    Sorry for the bother, I'm just not sure this is meant to work with BuddyPress (and it doesn't appear to).

    Thanks!

  • myemedia

    No error messages site works fine, except it does not always send out the confirmation emails which has always occurred, hence the reason I installed the https://premium.wpmudev.org/project/remove-email-verification-from-signup/installation/ plugin. Now that this MU-plugin is installed nothing has changed. A new user still gets their email verification a lot of the time. And I have a collection of users who can not login to the site as they are waiting for the email verification

    If the email verification was working consistently I would not need to persist with trying to get this plug working. Hence if either issue was solved it would help greatly.

    Thanks @James for your update

  • Ulrich

    confirmation emails not sent

    The default php mail function is not 100% reliable, and there are also 100 other reasons which can prevent emails from being correctly delivered (e.g.: server setup, server ip or domain in a blacklist,...) especially on shared hosting.
    The workaround would be to configure WordPress to use an smtp server to send emails (e.g. gmail smtp server). Use this plugin: http://wordpress.org/extend/plugins/wp-mail-smtp/

    plugin not working

    Please deactivate in the admin all the plugins installed and remove all the other mu plugins from the directory "mu-plugins" and let me know if the plugin is still not working.

  • myemedia

    Third time lucky. The error reads:

    Test Message Sent

    The result was:

    bool(false)
    The full debugging output is shown below:

    object(PHPMailer)#181 (45) {
    ["Priority"]=>
    int(3)
    ["CharSet"]=>
    string(5) "UTF-8"
    ["ContentType"]=>
    string(10) "text/plain"
    ["Encoding"]=>
    string(4) "8bit"
    ["ErrorInfo"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."
    ["From"]=>
    string(25) "noreply@test.carobowl.com"
    ["FromName"]=>
    string(22) "CaroBowl.com test site"
    ["Sender"]=>
    string(0) ""
    ["Subject"]=>
    string(53) "WP Mail SMTP: Test mail to craig@humanpotential.co.nz"
    ["Body"]=>
    string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
    ["AltBody"]=>
    string(0) ""
    ["WordWrap"]=>
    int(0)
    ["Mailer"]=>
    string(4) "smtp"
    ["Sendmail"]=>
    string(18) "/usr/sbin/sendmail"
    ["PluginDir"]=>
    string(0) ""
    ["Version"]=>
    string(5) "2.0.4"
    ["ConfirmReadingTo"]=>
    string(0) ""
    ["Hostname"]=>
    string(0) ""
    ["MessageID"]=>
    string(0) ""
    ["Host"]=>
    string(23) "host111.hostmonster.com"
    ["Port"]=>
    string(3) "465"
    ["Helo"]=>
    string(0) ""
    ["SMTPSecure"]=>
    string(3) "ssl"
    ["SMTPAuth"]=>
    bool(true)
    ["Username"]=>
    string(18) "admin@carobowl.com"
    ["Password"]=>
    string(13) "wordpress1234"
    ["Timeout"]=>
    int(10)
    ["SMTPDebug"]=>
    int(2)
    ["SMTPKeepAlive"]=>
    bool(false)
    ["SingleTo"]=>
    bool(false)
    ["smtp"]=>
    object(SMTP)#42 (7) {
    ["SMTP_PORT"]=>
    int(25)
    ["CRLF"]=>
    string(2) "
    "
    ["do_debug"]=>
    int(2)
    ["do_verp"]=>
    bool(false)
    ["smtp_conn"]=>
    resource(331) of type (stream)
    ["error"]=>
    NULL
    ["helo_rply"]=>
    string(137) "250-host111.hostmonster.com Hello test.carobowl.com [74.220.207.111]
    250-SIZE 52428800
    250-PIPELINING
    250-AUTH PLAIN LOGIN
    250 HELP
    "
    }
    ["to"]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(26) "craig@humanpotential.co.nz"
    [1]=>
    string(0) ""
    }
    }
    ["cc"]=>
    array(0) {
    }
    ["bcc"]=>
    array(0) {
    }
    ["ReplyTo"]=>
    array(0) {
    }
    ["attachment"]=>
    array(0) {
    }
    ["CustomHeader"]=>
    array(0) {
    }
    ["message_type"]=>
    string(5) "plain"
    ["boundary"]=>
    array(2) {
    [1]=>
    string(35) "b1_450f9aae9619e58378f95097d95055f7"
    [2]=>
    string(35) "b2_450f9aae9619e58378f95097d95055f7"
    }
    ["language"]=>
    array(13) {
    ["mailer_not_supported"]=>
    string(25) " mailer is not supported."
    ["provide_address"]=>
    string(55) "You must provide at least one mailer is not supported."
    ["execute"]=>
    string(19) "Could not execute: "
    ["instantiate"]=>
    string(36) "Could not instantiate mail function."
    ["authenticate"]=>
    string(35) "SMTP Error: Could not authenticate."
    ["from_failed"]=>
    string(35) "The following From address failed: "
    ["data_not_accepted"]=>
    string(30) "SMTP Error: Data not accepted."
    ["recipients_failed"]=>
    string(56) "SMTP Error: The following SMTP Error: Data not accepted."
    ["connect_host"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."
    ["file_access"]=>
    string(23) "Could not access file: "
    ["file_open"]=>
    string(33) "File Error: Could not open file: "
    ["encoding"]=>
    string(18) "Unknown encoding: "
    ["signing"]=>
    string(15) "Signing Error: "
    }
    ["error_count"]=>
    int(2)
    ["LE"]=>
    string(1) "
    "
    ["sign_cert_file"]=>
    string(0) ""
    ["sign_key_file"]=>
    string(0) ""
    ["sign_key_pass"]=>
    string(0) ""
    }
    The SMTP debugging output is shown below:

    SMTP -> FROM SERVER:
    220-host111.hostmonster.com ESMTP Exim 4.69 #1 Tue, 05 Oct 2010 04:30:37 -0600
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.
    SMTP -> FROM SERVER:
    250-host111.hostmonster.com Hello test.carobowl.com [74.220.207.111]
    250-SIZE 52428800
    250-PIPELINING
    250-AUTH PLAIN LOGIN
    250 HELP
    SMTP -> ERROR: Password not accepted from server: 535 Incorrect authentication data

    SMTP -> FROM SERVER:
    250 Reset OK

    From
    From Email:

    You can specify the email address that emails should be sent from. If you leave this blank, the admin email will be used.

    From Name:

    You can specify the name that emails should be sent from. If you leave this blank, the emails will be sent from WordPress.

    Mailer
    Mailer:
    Send all WordPress emails via SMTP.

    Use the PHP mail() function to send emails.

    SMTP Options
    These options only apply if you have chosen to send mail by SMTP above.

    SMTP Host:
    SMTP Port:
    Encryption:
    No encryption.

    Use SSL encryption.

    Use TLS encryption. This is not the same as STARTTLS. For most servers SSL is the recommended option.

    Authentication:
    No: Do not use SMTP authentication.

    Yes: Use SMTP authentication.

    If this is set to no, the values below are ignored.

    Username:
    Password:

    Send a Test Email
    To:

    Type an email address here and then click Send Test to generate a test email.

  • myemedia

    Hey thanks for all your help @Ulrich. And thanks for hanging in with me on this. I may appear stupid but I did try changing the password etc before sending you that last message but seems like I still some how got it wrong.

    I have activated the http://wordpress.org/extend/plugins/wp-mail-smtp/ plugin on my real site http://www.carobowl.com after deactivity all other plugins. Then when I activated it I received this error message.
    ----------------------------------
    The plugin generated 184 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.
    --------------------------------------
    I carried on assuming it may work and have progressed to recevie this message after setting up the correct SMTP password etc:
    --------------------------------------------

    Test Message Sent

    The result was:

    bool(false)
    The full debugging output is shown below:

    object(PHPMailer)#96 (45) {
    ["Priority"]=>
    int(3)
    ["CharSet"]=>
    string(5) "UTF-8"
    ["ContentType"]=>
    string(10) "text/plain"
    ["Encoding"]=>
    string(4) "8bit"
    ["ErrorInfo"]=>
    string(82) "SMTP Error: The following SMTP Error: Data not accepted.craig@humanpotential.co.nz"
    ["From"]=>
    string(24) "noreply@www.carobowl.com"
    ["FromName"]=>
    string(12) "CaroBowl.com"
    ["Sender"]=>
    string(0) ""
    ["Subject"]=>
    string(53) "WP Mail SMTP: Test mail to craig@humanpotential.co.nz"
    ["Body"]=>
    string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
    ["AltBody"]=>
    string(0) ""
    ["WordWrap"]=>
    int(0)
    ["Mailer"]=>
    string(4) "smtp"
    ["Sendmail"]=>
    string(18) "/usr/sbin/sendmail"
    ["PluginDir"]=>
    string(0) ""
    ["Version"]=>
    string(5) "2.0.4"
    ["ConfirmReadingTo"]=>
    string(0) ""
    ["Hostname"]=>
    string(0) ""
    ["MessageID"]=>
    string(0) ""
    ["Host"]=>
    string(23) "host111.hostmonster.com"
    ["Port"]=>
    string(3) "465"
    ["Helo"]=>
    string(0) ""
    ["SMTPSecure"]=>
    string(3) "ssl"
    ["SMTPAuth"]=>
    bool(true)
    ["Username"]=>
    string(18) "admin@carobowl.com"
    ["Password"]=>
    string(13) "wordpress1234"
    ["Timeout"]=>
    int(10)
    ["SMTPDebug"]=>
    int(2)
    ["SMTPKeepAlive"]=>
    bool(false)
    ["SingleTo"]=>
    bool(false)
    ["smtp"]=>
    object(SMTP)#97 (7) {
    ["SMTP_PORT"]=>
    int(25)
    ["CRLF"]=>
    string(2) "
    "
    ["do_debug"]=>
    int(2)
    ["do_verp"]=>
    bool(false)
    ["smtp_conn"]=>
    resource(406) of type (stream)
    ["error"]=>
    NULL
    ["helo_rply"]=>
    string(136) "250-host111.hostmonster.com Hello http://www.carobowl.com [74.220.207.111]
    250-SIZE 52428800
    250-PIPELINING
    250-AUTH PLAIN LOGIN
    250 HELP
    "
    }
    ["to"]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(26) "craig@humanpotential.co.nz"
    [1]=>
    string(0) ""
    }
    }
    ["cc"]=>
    array(0) {
    }
    ["bcc"]=>
    array(0) {
    }
    ["ReplyTo"]=>
    array(0) {
    }
    ["attachment"]=>
    array(0) {
    }
    ["CustomHeader"]=>
    array(0) {
    }
    ["message_type"]=>
    string(5) "plain"
    ["boundary"]=>
    array(2) {
    [1]=>
    string(35) "b1_30fff5991675cdf89c73c7802d72e724"
    [2]=>
    string(35) "b2_30fff5991675cdf89c73c7802d72e724"
    }
    ["language"]=>
    array(13) {
    ["mailer_not_supported"]=>
    string(25) " mailer is not supported."
    ["provide_address"]=>
    string(55) "You must provide at least one mailer is not supported."
    ["execute"]=>
    string(19) "Could not execute: "
    ["instantiate"]=>
    string(36) "Could not instantiate mail function."
    ["authenticate"]=>
    string(35) "SMTP Error: Could not authenticate."
    ["from_failed"]=>
    string(35) "The following From address failed: "
    ["data_not_accepted"]=>
    string(30) "SMTP Error: Data not accepted."
    ["recipients_failed"]=>
    string(56) "SMTP Error: The following SMTP Error: Data not accepted."
    ["connect_host"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."
    ["file_access"]=>
    string(23) "Could not access file: "
    ["file_open"]=>
    string(33) "File Error: Could not open file: "
    ["encoding"]=>
    string(18) "Unknown encoding: "
    ["signing"]=>
    string(15) "Signing Error: "
    }
    ["error_count"]=>
    int(1)
    ["LE"]=>
    string(1) "
    "
    ["sign_cert_file"]=>
    string(0) ""
    ["sign_key_file"]=>
    string(0) ""
    ["sign_key_pass"]=>
    string(0) ""
    }
    The SMTP debugging output is shown below:

    SMTP -> FROM SERVER:
    220-host111.hostmonster.com ESMTP Exim 4.69 #1 Tue, 05 Oct 2010 11:33:53 -0600
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.
    SMTP -> FROM SERVER:
    250-host111.hostmonster.com Hello http://www.carobowl.com [74.220.207.111]
    250-SIZE 52428800
    250-PIPELINING
    250-AUTH PLAIN LOGIN
    250 HELP
    SMTP -> FROM SERVER:
    250 OK
    SMTP -> FROM SERVER:
    451 Temporary local problem - please try later
    SMTP -> ERROR: RCPT not accepted from server: 451 Temporary local problem - please try later

    SMTP -> FROM SERVER:
    250 Reset OK

  • myemedia

    Solved now - The hosting company told me to swap outgoing mail server from "host111.hostmonster.com" to "localhost' and now seems to be working.

    Thanks tremendously for all your help @Ulrich and others.

    I have about 20 users now who have not become members because I guess they have no activation email. I guess unless I do something like reset their password and emailed them the new password they will not ever be able to use the site.

  • myemedia

    I tested it originally and the email worked fine for me. Then I got feeback from some users that email verifiactions only worked interminetly, hence why I tried using the removing email verification plugin. After giving up on that after many attempts as above, we swapped to using SMPT email which was finally solved now.

    I had a test site if that is what you call a test bed? And tried it all on my test bed before doing it on the real site. But yes I still have a load to learn no doubt.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.