Instructor Management page error: Undefined index: has_published_posts

I'm not able to add an existing or new user as an instructor after upgrade to WP 4.3.1. And, I saw the following error in instructor listing page.

Notice: Undefined index: has_published_posts in /nas/wp/www/cluster-40172/tjclearn/wp-includes/user.php on line 662

  • Ash

    Hello @Daren

    I hope you are well today and thanks for asking the question.

    This is not an error but just a notice which is not harmful to the user but helpful to the developer. I am letting the developer but for now, would you please disable debug mode and check if any error is shown in that page?

    To disable debug mode please edit a line in your wp-config.php:
    Change

    define('WP_DEBUG', true);

    to

    define('WP_DEBUG', false);

    Cheers
    Ash

  • Ash

    Hello @Darren

    However, I still have problem to add an existing user or new user into the instructor management page now. When I click "Add new" instructor, it redirected me to "Add a new" user page.

    This is default behavior. An instructor has to be an user first. So, when you add an instructor in your system, ultimately you are adding an user in your system.

    You can assign an instructor to a course. To do that, you need to edit a course and in step 3 you can assign instructor to a course.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.