"Request Failed, try again" for some users

Using the login page that is included with M2, I have a very small subset of users who can neither login or reset their password. Each attempt is met with "Request Failed, try again". I have disabled all other plugins while testing with one of these users with no success. I have checked my Apache error logs and see nothing related to M2 or the customer's IP address. The strange thing is that most (if not all) of the effected users are in the UK.

Error Process:
- User attempts to login at https://graffitisuite.com/account/ using valid username and password
- Login form begins working
- Login form then displays error "Request Failed, try again"

Plugins I disabled for testing:
- WordFence Security
- Google Captcha (reCAPTCHA) by BestWebSoft
- WP Super Cache

PHP.ini Modifications for Troubleshooting:
upload_max_filesize = 100M
post_max_size = 105M
memory_limit = 768M
file_uploads = On
max_execution_time = 500

I have been unable to replicate this on any of my machines and browsers, and had to replicate it on an effected user's system via TeamViewer. Is there some other way of tracking this down that I haven't seen? Under what conditions is this incredibly unhelpful error shown?

I have read all of the other threads here that I can find on this issue, with no luck.

Checking the JavaScript console I can see an error on these users' computers stating that there are multiple instances of the #_wpnonce field.

  • Predrag Dubajic

    Hi Anthony,

    Hope you're doing well.

    I asked my colleague from UK to test this and I tried using proxy to access your site from two different locations in UK but we still couldn't replicate the issue.

    Do you know which browser and OS, and their versions, are those members using?
    Do they have any browser extensions installed?

    Apart from the apache log, do you also have WP debug log enable to see if that catches any errors?
    If not, you can enable it in your wp-config.php file (located in root WP folder) by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    If there are any errors when you try to reset password or login it should create debug.log file in your wp-content folder.
    Perhaps we can get some info about what's going on from there?

    Best regards,
    Predrag

  • Anthony G. Cyphers

    Thanks for the responses.

    About those browsers you listed, is this what you tried from your end and wasn't able to replicate or were those the ones that the users having the issues are using?

    I tested all of the same browsers (and browser versions) from my Windows and MacOS boxes as my test user did on MacOS and in a Windows 10 VM.

    Under what conditions is this error shown?

    What are the conditions which would cause a login or password reset action to result in this error being displayed from the M2 front-end forms?

    I checked WordFence a bit ago when the user again reported the failure and WordFence indicates that the login was successful, but M2 still denied their login with this error message.

  • Predrag Dubajic

    Hi Anthony,

    It's a general error when something prevents users from logging in, previous reports for this were usually due to security plugins blocking the access.

    You mentioned before that you already tried disabling other plugins on your installation, does that include WordFence as well, or was that still active during the test?
    Also, do you have any security rules added by WordFence inside your wp-config.php or .htaccess files because those would stay there even if the plugin is deactivated?

    Could you grant me support access to your site so I can check your setup?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Anthony,

    I checked your setup and only thing I see that's related to previous reports is Wordfence > Tools > Comment Spam filter, but if the plugin was already disabled during the tests I guess that's not the cause.

    It's really hard to find any further information since we can't replicate the issue :slight_frown:

    Did you get any info in your debug.log in the meantime?

    Also, can you try creating a new user yourself and ask the members with issue to login/reset password with that so we can see if this is perhaps account related?

    Best regards,
    Predrag