Internal Server Error After Creating New Site

Last fall I started setting up my new WPMU network on my VPS. After debugging the mapping plug-in and some settings on the server, we got five sites up and working and they continue to do so, although they’re still under development. See post 310311.

However, I’ve acquired some more domain names and went to set up some more sites on my server.

The initial “add new” site via the WPMU network dashboard appeared to work OK. However when I try to access the newly create site’s own dashboard, I get an “Internal Server Error” message with a secondary 500 server error.

I also tried to access the full URL and the .com URL for the blog, and for both I get the same “Index of /” displayed with cgi-bin/ on the next line.

My hosting provider’s excellent technical support folks are still looking into it from their end, but so far they believe everything is configured properly. We have the working sites to compare the settings with.

The only changes I’ve made since setting up the first sites is the regular WP and WPMU updates.

Does anyone on this forum have any ideas?

Thanks

  • aecnu
    • WP Unicorn

    Greetings Temporal Sales,

    Sorry to see that you are having an issue with your WordPress installation and new domains via domain mapping.

    The first thing to check is can you reach the sub site?

    If so the next thing to check is if you folks have indeed replaced the sunrise.php file that comes with the newer version of Domain Mapping?

    Please advise.

    Cheers, Joe

  • Temporal Sales
    • Site Builder, Child of Zeus

    By “sub site” do you mean can I reach it typing http://newblog.mysite.com in my browser?

    The answer would be “no” for the most part in that I get the CGI file as shown in the third screenshot. I see the same thing if I type in http://newblog.com as well.

    I’ll check the file dates on the sunrise.php file. I haven’t done anything with it since installing it last fall. But several automatic updates have been run since then.

    Thanks!

  • Temporal Sales
    • Site Builder, Child of Zeus

    Update:

    I checked my sunrise.php file in the wp-content directory and saw that it wasn’t being updated by the auto-updates.

    I replaced it with the latest but so far the same problem persists. If I try to access the new dashboard or the new wp-login for the site I get an internal server error message.

    Thanks!

  • Temporal Sales
    • Site Builder, Child of Zeus

    Update:

    I’ve removed and reinstalled my mapping plug-in with the latest version, and made sure the latest sunrise.php was copied over to the wp-content directory.

    I then tried adding a new site and unfortunately it didn’t help as I can’t open the dashboards of any newly created sites.

    However, I have no problems accessing my older sites, which suggests this may not be a mapping problem.

    Any ideas?

  • Temporal Sales
    • Site Builder, Child of Zeus

    Update:

    My hosting service has reviewed the error messages and offered the following insights:

    “I’ve parsed the error log and found this erorr, I believe this error is

    responsible for your 500 errors you are seeing.

    [Tue Mar 12 17:47:03 2013] [error] [client 74.136.85.77] Request exceeded the

    limit of 10 internal redirects due to probable configuration error. Use

    ‘LimitInternalRecursion’ to increase the limit if necessary. Use

    ‘LogLevel debug’ to get a backtrace., referer:

    http://homesafetyreviews.temporalsales.net/wp-admin/

    This error is almost always caused by some bad code in an .htaccess file. You

    may have to comment out some lines in this file or remove it completely.”

    Any ideas what this means from the WPMUDev context?

    Thanks!

  • Temporal Sales
    • Site Builder, Child of Zeus

    To add, here’s my .htaccess file. It’s as installed last November and I’ve made no changes.

    # BEGIN WordPress

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ – [L]

    # uploaded files

    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule ^ – [L]

    RewriteRule . index.php [L]

    # END WordPress

    Thanks!

  • Temporal Sales
    • Site Builder, Child of Zeus

    Follow-up:

    I see in other threads that some folks are having similar issues with the mapping plugin and .htaccess.

    In checking the WPMU CODEX, there is indeed a different .htaccess file for 3.4.x versus 3.5.x (I have the 3.4.x .htaccess file although I’ve since upgraded my system to 3.5.x)

    However, the CODEX contains an admonishment stating that those who installed 3.4.x mutli-site in the subdirectory format should continue using the 3.4 .htaccess file even after upgrading their systems to 3.5.x.

    However, I’m using the subdomain setup and the 3.5.x examples don’t contain the same warning.

    Since this is way over my head, could someone advise whether or not it’s safe to try the 3.5.x .htaccess file? A temporary outage or an error message is acceptable, but I didn’t want to risk anything worse.

    Thanks!

    __________________

    http://codex.wordpress.org/Multisite_Network_Administration#.htaccess_and_Mod_Rewrite

  • Temporal Sales
    • Site Builder, Child of Zeus

    Update:

    My hosting service said it would be safe to try replacing my .htaccess file with the newer version.

    Unfortunately the newer version broke my site completely, but I was able to restore the old .htaccess file and regain access to my site.

    Nonetheless, the problem with the new sites persists.

    Any other ideas?

    Thanks

  • Paul Barthmaier
    • Code Wrangler

    Hi there,

    If you upgraded to 3.5, you’ll likely need to change your htaccess, but when you do, please be sure to reset your permalinks. That should help. The other thing you might try is to rename your htaccess, which is sort of like deleting it without deleting it. Apache should create a new htaccess for you. If it doesn’t you can try logging out and back in and then changing your permalinks to anything but the default. Doing that should get you a new htaccess that works for your current configuration.

    Hope this helps.

    Cheers,

    Paul

  • Temporal Sales
    • Site Builder, Child of Zeus

    Paul,

    Thank you! That was certainly a step in the right direction.

    I deleted the .htaccess file, changed my permalinks, logged in and out, and I could then create sites and access one of the new dashboards without the internal server error message.

    However, for the other new site, I keep getting 404 errors when I try to access it’s new dashboard. Perhaps that’s a mapping issue?

    Then for both sites, I get the “Index of /” when I try to access the full URL, such as homesafetyreviews.temporalsales.net”

    Also, when I deleted .htaccess I could never see if Apache replaced it. When I tried uploading a copy of the “new” .htaccess taken from the Codex, it broke my site, so I again deleted the .htaccess I had uploaded.

    Nonetheless, we’re making progress.

    Any other ideas?

  • Temporal Sales
    • Site Builder, Child of Zeus

    To follow-up, my hosting tech support says Apache will not re-create a deleted (or renamed) .htaccess file and such will have to be recreated manually.

    I’ve confirmed from the Codex that my “old” .htaccess file was the stock 3.4.x variant. But when I try replacing it with the 3.5.x version from the Codex, it breaks my entire site with an “Internal Server Error” message displayed.

    As far as my inability to access the dashboards of newly created sites, still no change there, except that with no .htaccess file I get a 404 “not found” error. With the 3.5.x .htaccess file I get the “Internal Server Error” message.

    Thanks

  • Temporal Sales
    • Site Builder, Child of Zeus

    To correct an earlier post, I cannot access any of my newly created sites.

    I thought I was able to access one this morning after deleting the .htaccess file, but as it turns out, there was a typo in the website name when I created it.

    So when i corrected that by creating a new site, it’s back to the same problem I’ve observed for the last two days,

    Thanks!

  • Temporal Sales
    • Site Builder, Child of Zeus

    Update:

    I’ve installed the 3.2 beta mapping plug-in and tried both versions of the .htaccess file, but the problems with the newly created sites remain.

    Attached is my latest screen shots taken with the .htaccess file removed.

    If I use the 3.4.x. file, I get the “Internal Server Error” messages anytime I try to access the newly created sites’ dashboard. If I use the 3.5.x file, I get the “Internal Server Error” message all the time as it completely breaks my sites, including the old sites created before the latest WPMU and WPMUDev updates.

    Any other ideas?

    Thanks!

  • Paul Barthmaier
    • Code Wrangler

    Is there any chance that you made a real subdomain on your cPanel and forgot about it? If you don’t have anything installed in there, that would explain why you are seeing the empty index and then with wp-admin, the 500 error.

    In fact, if you go to your homesafetyreviews.temporalsales.net, you’ll get the empty Index. but delete a letter out of homesafetyreviews and you’ll get something good. In fact, you can delete up to 16 letters of homesafetyreviews and you’ll pretty much get to the same place. This says to me that homesafetyreviews doesn’t live in your blogs table, which is where WordPress will look in order to create the subsite. So I reckon you’ve got something created from before that isn’t from Multisite.

    Make sense?

    Cheers,

    Paul

  • Temporal Sales
    • Site Builder, Child of Zeus

    Is there any chance that you made a real subdomain on your cPanel and forgot about it? If you don't have anything installed in there, that would explain why you are seeing the empty index and then with wp-admin, the 500 error.

    Attached are three snapshots of my cPanel setup:

    (1) Subdomain

    (2) Add-on Domains

    (3) DNS Zone File

    I'll have to check the ticket with my hosting service, but I think the homesafetyreviews subdomain was set up first before the site was created in WPMU. Are you saying that the subdomain should not be set up first?

    Better yet, is there a checklist written somewhere with the proper steps in the proper order?

    Say I acquire the "blog.com" domain name and I want to set it up on my WPMU server as blog1.mysite.com. What should step 1, step 2, step 3, etc. be?

    That would be big help to aid in my learning and it's something I could send to my hosting service so they can check the current settings from the top down.

    Thanks!

  • Paul Barthmaier
    • Code Wrangler

    Here’s the tutorial that helps explain it.

    https://premium.wpmudev.org/blog/how-to-map-domains-with-the-wpmu-dev-domain-mapping-plugin/

    There’s also a video in there. The Domain Mapping plugin revolves around Multisite, which means the sites are virtual, not add-on or sub-domains. So, the subdomain http://homesafetyreviews.temporalsales.net/ that was created in your cPanel wil have to go. You’ll create that in the WordPress multisite that you create at temporalsales.net, by going to your Network admin and Sites Add new.

    Hope this helps.

    Cheers,

    Paul

  • aecnu
    • WP Unicorn

    Greetings Temporal Sales,

    Holy smokes this is the first this ticket has made it to my screen since I first replied.

    How are you making out with this item now?

    Have you indeed managed to resolve it after jumping though all those hoops or?

    Please advise.

    Cheers, Joe

  • Temporal Sales
    • Site Builder, Child of Zeus

    We’re still having problems. Not only can I not open sites, but I can no longer view my images, be them recently uploaded or old. See my post 388906.

    Part of the problem is that I made the new site set-up more complex than it really was. But the issue with the images / permissions is really a mystery in that images I uploaded months ago are no longer viewable too.

    In that the site(s) are not commercially active, what my developer and I are going to do is re-install WPMU and reconfigure the sites from scratch. That should correct any problems I may have introduced while troubleshooting things myself.

    This approach is probably the most time-efficient at this point.

    Thanks!

  • aecnu
    • WP Unicorn

    Greetings Temporal Sales,

    Thank you for letting us know and the details as well which are greatly appreciated.

    I am going to mark this ticket as resolved for now until we hear back from you or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

  • Paul Barthmaier
    • Code Wrangler

    HI there,

    The issue with the images is likely related to your htaccess. If this is a Multisite that has been around a while and upgraded a few times, it can be tricky to find the correct rewrite rule, but it can be done. Still, it will be nicer if you can afford starting over since the 3.5 update did away with blogs.dir.

    Cheers,

    Paul

  • aecnu
    • WP Unicorn

    Greetings Temporal Sales,

    Thank you for the update and after fine tooth combing through this thread the one thing missing in your screen shot of the domains DNS from this post:

    https://premium.wpmudev.org/forums/topic/internal-server-error-after-creating-new-site#post-386437

    Is the asterisk/wildcard is missing from the DNS listing as it should appear as shown in my screen shot below.

    That is what in my opinion explains why the new sub domains did not work.

    In any event, please watch out for this very important detail in the future and have a GREAT week ahead!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.