Internal server error all over my site

I need urgent help - whenever one tries to access any site of my website (except for the starting page). I get "internal sever error". I already did define('WP_MEMORY_LIMIT','256M'); in the wp-config.php.

Maybe interesting as to the history of this error: I updated seven plugins today (including WPMUDEV-Dashboard and WP_Smush) and afterwards I had the internal server error even on login-page. After moving the plugin "WPS-Hide-Login" to the "plugins2-folder" I at least could login once again. However, for the frontend of my site it did not help.

Support access is granted, however you might need an extra Login and Password to access, so as soon as anyone of you will answer I will send it via the contact form.

  • Matthias
    • The Incredible Code Injector

    Update: Deactivating (nearly) all plugins did not change a thing :slight_frown:
    Update2: Restoring the Database to an earlier version did do the trick - however, I still would like to know, which plugin-update caused the problem. Any way to find that out?

  • Nastia
    • Support Rock Star

    Hello Matthias

    I am sorry to hear you have this issue!

    Any way to find that out?

    In order to find out what lugin caused this, pplease create a devlopment copy of your site. You ca do this with the Snapshot plugin:
    https://premium.wpmudev.org/project/snapshot/

    After this, please update one plugin at the time, to find the plugin that causes 500 error. Once you find it, do the check for a conflict.

    Deactivate all the plugins, except the one that was causing issues. If everything is working, activate one plugin at the time.

    Please follwo the directions from out manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let me know if you have any more questions!

    Cheers,
    Nasti

  • Matthias
    • The Incredible Code Injector

    Well, it happened again - now I am having Internal Server Error (500) on all pages except the starting page (www.hotel-oberkirch.de). Even the English version of the exact same page (www.hotel-oberkirch.de/en/) puts out this error.
    I tried to move all plugins to another folder via FTP - didn't change a thing, so now I am kind of clueless as to what I could do to get access to my page once again (login is impossible, too)

  • Matthias
    • The Incredible Code Injector

    So here is the next clue, I hope:
    [Thu Sep 01 16:27:33.409402 2016] [core:error] [pid 11901] [client 164.132.161.55:33322] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    How can that happen if I did not change anything except updating the custom sidebars plugin?

  • Nastia
    • Support Rock Star

    Hello Matthias , I hope you are doing well today!

    Have you installed or updated any of your plugins before this error shows up? Or you have made any change on your site before it?

    The 500 it is very general and provide a little information. Do you have access to your wp-admin dashboard?

    Rename your .htaccess file to .htaccessold, go into your WordPress admin area. Hover over Settings, and select Permalinks. Scroll down to the bottom of the page, and click Save Changes.

    Another solution is to increase the PHP Memory limit. Add this to the wp-config.php file:

    define('WP_MEMORY_LIMIT', '256M');

    Let me know if this helps!

    Cheers,
    Nastia

  • Matthias
    • The Incredible Code Injector

    Hi Nastia,

    thanks for your answer. The said memory limit I had done already. However, the reason was found (but not the cause, sadly). Somehow there came a rewrite base /fr/ into my .htaccess. Changing it back to / did the trick. However - as my .htaccess was not changed deliberately by me in ages, I still don't know what caused this modification (so I'm afraid it might come back any time)

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.